[BUG] Unable to login to forum without resetting password

Hi, I have been having issues logging in to the forum lately. When I click on the login button in the top right it takes me to the login page but shows a message saying "you are not authorized to view this page". There is also a message in the sidebar above the ad space that says "Forum, BRB maintenance". When I enter my email address and password it always rejects it and the same if I try using my username and password. If I go through the forgot password route that provides me with the link which logs me in. Then I change the password and can access my profile and post like I am now; on the same session. But if I log out or open a incognito window and try logging in again it rejects it even with the new password.

Is this a known issue or just a problem with my account? I seem to remember when I first signed up a while back I did so using the sign-in with Google option as opposed to a username and password. Maybe something has changed in the meantime and now my account is glitched.

I believe this is due to your browser settings for cookies. I get the same message when I log in. As far as the "Forum, BRB maintenance" text, that is likely something leftover that needs to be removed. Tagging @wendell about that.

Tried clearing my cookies and specifically allowing cookies from the teksyndicate site as well as running in an incognito window. But still no luck logging in without going the reset route.

A question, is the username field meant to work with an email address, username or user ID? I have tried: my associated email address, nathaniel_t, Nathaniel T, 158801.

Maybe I'll have to try creating a fresh account. It looks like plenty of other people can sign in with no problem and use the forum, but this is proving a real pain to access.

The username field is for a user ID (not an email address). If you signed up for the forums before the change over to Discourse (the current forum implementation) or if you ever had your username changed, then you need to sign in with the original username. For instance, my original username was Alamar (with underscore prefix and suffix) but I since had the underscores removed. However, when I log in I still need to use the original syntax with the underscores.

It looks like your username is "Nathaniel T"

1 Like

Thank you, thank you, thank you!

Yes, I believe I did sign up before the platform changed. That username works. The login status on the forum is still a bit buggy, but I can sign in and out properly.

1 Like

Np. Let us know if you have any other issues. Like I said before, the "Forum, BRB maintenance" text is likely an artifact that needs to be removed. I believe that using an incognito window may always cause the "you are not authorized to view this page" or similar warning message to be displayed. I'm not sure about that though but I thought I remembered reading this in a post in the past. Perhaps someone else can reply to this with more information.