[BUG] discobot greetings tutorial

I just recently setup my account and have never used a forum like this and had some time to kill so I thought I’d run through the tutorial from @discobot

All works well until you get to flagging an inappropriate post. The bot creates a message to flag as part of the tutorial but when flagged, it says the post hasn’t been flagged yet. I refreshed the page and attempted to flag the dummy/tutorial post several times until I received a message from a moderator telling me that they’re getting notifications and can see me actually trying to flag something.

After several attempts in the bot conversation, it still tells me that I haven’t flagged the post yet. Screenshots provided.


1 Like

Hi! To find out what I can do, say @discobot display help.

1 Like

Hmmm, interesting.

Did you flag it with the second option of “It’s inappropriate”, initially?

I could never actually get the tutorial to work for myself when I tried to run through it (although that was some time ago), so I can’t say what’s going on, for sure.

Might be time to investigate more.

1 Like

I only tried the “Other” option. It seems most appropriate but I would figure any should do for the test. I will try your suggestion shortly.


That seems to have worked.

Yeah, the tutorial requires a user to flag as inappropriate, anything else won’t work.

Presumably the coding on the backend isn’t robust enough to pick up anything other than exactly what it says to do in the tutorial.

The Vision™ strikes again!