Return to Level1Techs.com

Budget Ryzen Build : Random Reboots/Lockups

Hello everyone,

Just wanted to give my experience, good and bad, on building an affordable first gen Ryzen computer. I’m a hardware guy and I always build best bang-for-the-buck systems for myself and a few friends. I’m not a power user and I don’t need the best available hardware. It would be like paying for an exotic sports car just to go get groceries, my ford taurus works just fine. So in March of this year I decided to take advantage of the price reduction of AMD’s price reduction of it’s first gen cpus and motherboards. I was also building a system for a friend and so I purchased two 8 core cups as well as two B350 motherboards, one from Asrock and one from MSI.

You might want to cover your ears now. My friend runs Windows…Ok, safe to put your hands down now. I built his system first, loaded his OS, and ran a lot of stress tests to make sure there was no problems with his system. After a week or so of tests and running it real time I shipped it off to him.

Then I built my system. I initially loaded Linux Mint and had random lock-ups and reboots. So I switched to MX-Linux and had the same problems. After going through Xubuntu and Manjaro and still having these problems I figured I had faulty hardware. I swapped out memory, videocard, power supply, cpu, and motherboard with no fix in sight. By this time it was mid to late summer and many dollars later. I tried to search for others having these same problems and asked my friend if everything was working well for him. He was having no problems. I finally saw a video from Chris Titus Tech on youtube where he had the same problems with a new build and his fix was to change the Kernel on his system. This was what finally fixed my problems.

It is now November and with two Asrock motherboards and MSI motherboard my systems are the most stable on Liquorix series of kernels. You can find this at https://liquorix.net/ and if you’re on MX-Linux it is in the Kernel section of the popular software.

The down side to all this is that I can’t seem to get Virtualbox to run now. Not sure if it’s my kernel or my lack of understanding about what Virtalbox needs. With my old AMD-FX hardware I never had problems with it running.

I hope this saves someone out there a lot of time, money, and frustration!!!

God bless and take care,
JT

1 Like

You may need to ensure that SVM is enabled in BIOS. That is AMD’s version of hardware virtualization. And in my experience every BIOS update or OC failure will reset it to off.

Disable C-States in UEFI. Ryzen’s power management is a little wonky. It’s not the most useful feature on desktops and workstations, anyway.

Hey zlynx,
Verified SVM was enabled. Ended up building VB on my system from the supplied BASH script provided in the VB downloads section. Works well now.
Happy Thanksgiving!
JT

1 Like

Hey Imhight.today,
I use MBR instead of UEFI and could not find C-State in BIOS. Ended up building VB on my system from the supplied BASH script provided in the VB downloads section. Works well now.
Happy Thanksgiving!
JT

whats your PSU?
can it handle your system? e.g. supply enough power.