Return to Level1Techs.com

BSODs and memory errors with XMP enabled - bad RAM sticks or just unlucky in the lottery?

amd
helpdesk
ryzen

#1

So I finally got around building a new PC and I’m having some issues now, after 3 weeks of trying to troubleshoot I’m out of ideas, so here I am. I hope I recount this correctly because it has been a few days of trial and error, but I can test again at any time.

First off, the hardware:
Gigabyte X470 Gaming 7
Ryzen 2700X
2x 8GB Corsair Vengeance RGB (CMR16GX4M2C3200C16W)
2x Crucial MX500 500GB
Sapphire Vega 64 Nitro

So first things first I don’t know anything about overclocking, but I assumed XMP should be fine on any system these days. I know that specific kit isn’t on the QVL for this specific motherboard, but they were cheaper then the LPX variant for some reason. Also it has a load of equivalent kits (i.e. equivalent timings/frequencies) on there and with the improvements on Ryzen and wendell even running 4 different sticks at like 2933 I assumed… it can’t be so bad right.

So, when I built the system I updated the UEFI (after installing Windows because I didn’t have access to another PC to build a USB drive), then set the XMP profile.
Did some basic benchmarks to compare whether the performance was anywhere near it was supposed to be, and it was.
Loaded up Prime95 and Furmark for a while and it was fine, so it is stable under temperature and power draw.

So now for the issue, started playing Overwatch a little and after maybe 10 minutes of play I would get a BSOD for MEMORY_MANAGEMENT, after restart and again 10 minutes of play it would BSOD again with IRQL_NOT_LESS_OR_EQUAL. Another restart and it would instantly BSOD without even getting into Windows, but I can’t remember the code exactly, I think it was PFN_LIST_CORRUPT. Anywy, first thing I did was disabling XMP and it seemed fine after that.

Guessing I had a faulty RAM I ran Memtest86 overnight… well… actually, I tried, because when I looked at it the next morning it stopped after a few tests after a whopping 11220 errors.
The next thing I did was follow Corsairs advice and entered the timings manually. I only changed the primary timings and left the rest alone (because as above, I have no idea about overclocking and I don’t even know what the values mean). Memtest still threw some errors, but way less at 111 through the whole run.

So I disabled XMP for the day and ran Memtest again in the night, it ran through 3 runs and it was fine with no errors found. Switched back and forth a few times to confirm XMP was an issue and it was.
Next thing I did was pressing the clear-CMOS a bunch of times and trying the same again, with the same results, i.e. fine without XMP, but memory errors once enabled.

So yesterday I ripped out one of two RAM sticks (from bank 2, so bank 1 is remaining), and memtest ran fine overnight even with XMP enabled.
This could just be because the IMC is getting hammered less, but I can’t really test for that so… there’s that.
Then earlier I got a BSOD MEMORY_MANAGEMENT again with XMP enabled, even though memtest ran fine for 5 rounds of tests. Disabled XMP, now I even got a system hang (not BSOD) earlier…

So basically I’m at a loss. I’d understand if there were issues with getting the frequencies to run, but now I’m even getting hangs at stock settings…

So I’m not sure what to do. Of course I still have warranty, but as memtest can’t even detect it apparently, I wouldn’t know what to tell the vendor. There’s also no specific tasks in Windows that are having issues (well, [email protected] maybe, see below).

Another issue I have that may or may not be related is when running [email protected] on the Vega. In the 3 weeks I tried it, it finished a whopping 2 work units and keeps throwing bad work unit errors (19:51:07:WU02:FS01:0x21:Bad State detected... attempting to resume from last good checkpoint. Is your system overclocked?), and asking me whether the system was overclocked. Well, yes technically with the XMP, and the GPU is factory overclocked, but I never had issues with factory overclocks before (R9 390 Nitro previously).

So, any ideas what to do or how to get this thing stable? The hang earlier might just have been Windows being derp (since it was the first time it hanged instead of BSODed), but I would also like to run the RAM at its rated speed because… y’know, Ryzen is Ryzen. I could crank up the voltage but I would prefer not having to, also not knowing what is even safe in the first place.
Also I should note that the Corsair site states that there are 2 XMP profiles on the sticks, but the UEFI only shows one. This could be some generic info that doesn’t apply to my kit though.