Broken Windows after dual-booting with Kali Linux

2 days ago I created a 120gb partition on one of my hard drives to install Kali Linux to. I wasn't too sure about what I was doing and I was an idiot and forgot to unplug my second hard drive. I am fairly sure I installed grub to my second hard drive and I know I installed Kali onto my main hard drive. Whenever I try to boot into Windows using the Windows boot manager, Windows will start to load then my screen will output a sold color and freeze. The colors I've seen are yellow, light grey, light green, and light blue. The first time I tried to load Windows after installing Kali, it got to the login screen. I logged in, but then it turned a color and froze. I have tried automatically and manually adding Windows to grub, but the automatic way didn't detect it and the manual way gives me an error. I can get to the advanced startup options and I've tried everything in there except resetting Windows. My system specs are, an Fx-8320 (Overclocked to 4.2GHz), GTX 660, 2x 1TB WD Caviar Blues, CX600M, Asus M5A97 R2.0, 8 gb 1333 DDR-3 (Overclocked to 1600 MHz), a K95 rgb, and a G502 Proteus Core.

Did you resize the disk with Windows or Linux? That's a common problem if you use the Linux CD to resize. I'd recommend grabbing all the files you want to keep from Windows using the Linux boot and fresh install Windows. You might still need to reinstall grub after that since I don't think Windows prompts you if it finds an existing boot loader.

I used the Windows disk management to resize my disk. If nothing works I'll reinstall Windows, but I'd rather not.

I'm out then, I've never seen that happen if you resized before hand in Windows disk management.

Here is what update-grub2 gives me after manually entering Windows into 40_custom: [email protected]:~$ sudo update-grub2
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-4.0.0-kali1-amd64
Found initrd image: /boot/initrd.img-4.0.0-kali1-amd64
No volume groups found
error: out of memory.
error: syntax error.
error: Incorrect command.
error: syntax error.
Syntax error at line 202
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub/ file attached.

This is what I have in 40_custom: `
exec tail -n +3 $0

This file provides an easy way to add custom menu entries. Simply type the

menu entries you want to add after this comment. Be careful not to change

the 'exec tail' line above.

menuentry ‘Windows 10′ {
set root='(hd1,msdos4)’
chainloader +1

Edit: The forum did something weird and made that text big. It has a # in the file so it's commented out.

Try wrapping the output in [ code ] blocks.

Gparted says Windows is in /dev/sdb4.

I think I fixed it. Windows created a system restore when it was updating and I think I shut down windows while updates were going on and it didn't stop me. In the advanced startup options I did a system restore it said it failed but then windows booted up. It created a new user but the old user is still there I'm in windows right now on the new user. I am backing up the old user's folder and am going to create a new user with the same name then replace the folder, sign out, then sign back in or reboot. Lesson learned - windows is garbage, but most of my games are windows only.