Bridge mode?

I've finished building a pfSense box. I was going to use a D-link modem however this goes to unable to connect adter I log in, helpful.

How do I make my isp supplied modem router act as just a modem? Will just disabling DHCP & NAT achieve this?

What modem is it and what kind of internet connection do you have (cable, dsl, etc). If when you configure the modem your WAN interface gets a public IP then it's working, if you get a private IP or no IP then it's not.

The modem router is an ee brightbox 2, Internet connection is adsl.

this might be a stupid idea but wouldnt placing the pfsense box in the dmz be enough.

I can't find any info on it. A lot of the time ISP modems lack these sorts of settings. If there's nothing in the WAN configuration for bridge mode or something similar (sometimes it's called pppoe forwarding) then your best bet is to just get another modem, they're pretty cheap when you just want a modem.

Otherwise like @Dje4321 says you could just add the pfsense WAN interface addess as the DMZ on the modem (assuming it has that option. You'll need to make sure that the pfsense WAN interface address is in the same subnet as the modem's LAN address (so if the modem is then set the pfsense WAN address to etc. also make sure that the pfsense LAN address is in a different subnet). This isn't ideal but it should work.

Couldn't find anything either. Thanks for your help. I'll try to get the D-link modem to stop being a dick I think.

What's the problem with the d-link modem?

Go to its ip, log in box pops up, log in then it goes to can't connect. See further details says "computer missing some network protocols". There seems to be quite a bit of information out there about this so I''ll get playing. Thanks for your time.

Modem sorted, pfsense working, wireless access point working. Today is a very good day.

1 Like

what did you do?

Reset winsock and the modem behaved after that.