Return to Level1Techs.com

Bridge mode on modem/router combo not working

linux
helpdesk
#1

Dear network masters, my cry for help goes to all of you (jk obviously).
Things are pretty easy but hard at the same time: my provider gave me a Nokia G-240W-B modem/router combo. It’s a piece of garbage and they keep resetting it because they have issues on the line (go figure how resetting my modem to death will fix those) and it’s pretty shit settings wise. So I decided to use my trusty old Fritz!Box 7490 as a router to avoid getting pissed one day and the next one too.
But there’s a big problem in all of this. I switched one port on the router to bridge mode in order to connect the Fritz!Box to it. Then I started up the Frizt!Box, wiped it, start from scratch, follow the steps carefully (just told me to use the LAN port 1 as a WAN port, that’s it) and nothing happens.
The Nokia modem/router says the port I switched to bridge is dead and the Fritz!Box is reporting no internet connection. What did I do wrong? What kind of shenanigans is this? Thanks for all the answers!

0 Likes

#2

connect a laptop to the bridged modem/router and see if you get connection

1 Like

#3

I don’t, that’s how I’m accessing the bridged router.

P.S. the modem has connection, the bridge router doesen’t

P.P.S. connecting a PC to the bridged port leads to nothing, like the port is switched off. LAN ports LED on my notebook are off

0 Likes

#4

you have tried rebooting the modem with device plugged in?

have you tried setting the IP and GW on your testing device and pinging out?

1 Like

#5

The modem restarts automatically when setting a port to bridge mode.

The router has no settings whatsoever regarding IP or GW (I don’t know what that is). It just assigns itself a new local IP and does all the magic in the background

0 Likes

#6

well when you switch it to bridge mode it will pass the public IP/GW to the device on (most use) port 1. if your devices are not getting a response via DHCP you can traceroute to find the GW and set the IP and GW in a device on port 1 while the modems in bridge mode. you will likely be given the same IP every time that modem comes up.

to use network you will need at the least IP/GW on a home network it would be something like:

IP:192.168.1.14
GW:192.168.1.1

the device gets a ip and anything going out of the network goes to the GW, its the same on that modem as well, it may get something like:

IP:174.82.15.132
GW:174.82.15.1

1 Like

#7

Ooh the gateway. I don’t get the meaning of your response, I’m sorry. I’ll try to explain myself better:
the modem/router my provider sent me works, every device can access the internet. When I switch one port to “bridge” the connection the port goes dead. It doesen’t even light up the ethernet port on my laptop (it shouldn’t work, but there should be something going through right?). So then not even the router I want to use work has any connection.

0 Likes

#8

why not then just set your router device on the DMZ?

1 Like

#9

If you can you may have to manually set the link speed of the port connecting to the modem to 100mbps

1 Like

#10

have you verified that all other ports do not work? bridge mode is only going to serve one port

1 Like

#11

@Adubs Is it the same thing? I’d like to manage all the port forwarding, DNS and so on through the router and avoid completly the modem.

@Dexter_Kane I can’t do it, I have a gigabit internet connection so it would cripple me pretty hard. Also there isn’t any option on the modem to set one port to 100Mbit. It’s locked down pretty badly.

@kenkoda Only the port set to bridge stops working. All the others work flawlessly.
P.S. it happens the opposite. Why would all the other ports stop working if there’s the option to have just one serving as bridge?

0 Likes

#12

I meant that it could be an issue with auto negociation. On your router you may gave an option to manually set the port link speed (set it to whatever speed the port should be). Your laptop will definitely have this option so you can test it by connecting the laptop directly to the modem.

It’s pretty unlikely but you may need a crossover cable, although if the ports are gigabit that’s pretty unlikely.

1 Like

#13

I can’t set port speed on the WAN assigned port on the router and from the modem. I can only set port speed on the router going to other devices (useless).
Anyway setting it to 100Mbit would be a waste, I wouldn’t be able to use the gigabit internet connection I have.

All the network ports I’m using are gigabit and work accordingly without any issue.

How would a crossover cable solve the issue?

P.S. I specified the modem/router model (Nokia G-240W-B) and the router (Fritz!Box 7490) to help you help me figure out if there’s something wrong with one of those, especially the modem/router

0 Likes

#14

Putting your fritzbox on the dmz would mean you can manage all the ports and stuff on it instead of the combo. The difference is the combo will still be broadcasting and acting as it does for anything else that connects to it.

Some connection types in the past required this type of cable because they used transmit and receive pairs that were in the same spot on the pins. You can check your cable to see if it is by looking at the green and orange pairs. They should be opposite from each other. These days it almost never matters because most everything should auto negotiate transmitter and receive. In the case of gigabit, it’s auto negotiated. Back in the day it was not part of the 100baseT standard but still a lot of things had it.

1 Like

#15

If the ISP keeps resetting the modem/router to its default state, there’s not a damn thing that you can do about it, apart from complaining. Simply build your network around that sad reality, so that your network configuration does not constantly change.

If the modem’s default LAN address is 192.168.1.1/24, then I would manually configure the WAN port of the FritzBox to 192.168.1.2 and then have the FritzBox’s DHCP server hand out 172.16.xx.xxx to your network.

Normally you’d want to turn off any service in the modem/router that isn’t absolutely necessary, including DHCP, DNS, NTP, WiFi and etc., but if it is constantly being reset, there is no point in trying to swim upstream. As best as you can, configure the FritzBox to ignore all of the services being provided by the modem, by running your own NTP server, DNS resolver and DNSSEC, etc.

Bottom line, if consumer grade routers (and ISPs) were worth a damn, then MikroTik and Ubiquiti would be out of business and folks like me wouldn’t feel the need to run pfSense at home.

1 Like

#16

So it’s the exact same that I wanted to do right? I have one question still: I was trying to use just one port bridged so that means everything else on the router was still broadcasting and working as usual. So basically no difference between DMZ and one port bridge. Am I going to lose speed or increase the latency by much if I use the DMZ instead of the bridged port (which doesen’t work or I don’t know how to make work)?

0 Likes

#17

That’s what I’m trying to do, I want to isolate myself from the modem/router my ISP provided. I don’t want to argue on the phone for hours with unprepared staff that’s why I’m asking you knowldgeable people how to solve this issue. I’ll disable ALL the services from the ISP modem/router once I’m done.

0 Likes

#18

Dmz means the router function is still working 100% on your combo device. You are telling it to take a specific ip and just pass every port to it as if it was open to the internet. Normally this is bad but since it’s to another router, it’s fine.

1 Like

#19

You know I’ll be grateful to you for the rest of my life, right?
So the answer to my question before is “yes”, no difference between just bridging one port right?

P.S. should I reset the Fritz and take it back to factory or it still needs one port as WAN? This question is dumb, I know but I’m not sure lol

0 Likes

#20

It means the router is still doing inspections on packet headers to send them to the appropriate place. That will add overhead but hopefully it will be unnoticeable… But yes it’s funtionally the same result.

You will need a wan port indicating a router function on the fritzbox. I’m not familiar with them so that one is up to you.

Lastly you’ll want to try to disable the wifi on the ISP hardware so it doesn’t cause interference.

1 Like