Return to Level1Techs.com

Borderlands 3 Wine Gaming on Linux Troubleshooting

Hi guys. Went to Protondb and discovered that Borderlands 3 runs on linux, through steamplay adding wine prefixes and media foundation dll. Unfortunately, after following the steps I found there and in a video by “Intelligent Gamming” nothing happened, game doesn’t start. Can you help me?
My hardware and OS: xubuntu 18.04, kernel 5.3.0-42, Ryzen 3600, 16GB, RX 590.

You might want to enable the HWE stack for your CPU if you havent yet.

It is already installed and i guess enabled.

Are you aware that there are projects like “GloriousEggroll proton-ge-custom”?
(I would give a link but links are not allowed :slight_smile: i guess give it a search)
that are custom proton builds that you can install and tell steam to use for games.
That particular GitHub project above adds the common fixes and libraries needed for games such as the “media foundation” dlls. I’ve used it to run borderlands 3 myself and it works pretty well haven’t tried the dx12 option in the game though as of “Proton-5.4-GE-1” which was the release I’m currently using says in its release notes that dx12 mode doesn’t currently work for bl3.

I would relay the instructions on how to install it but I’d pretty much just be copy and pasting the instructions on the GitHub page, the only thing I’ll add is that you don’t need to compile anything just download the latest release from the release section.

2 Likes

is this the one?

I’ve heard good things, but never tried it:

let me know if you successfully fix:

  • the watch monitor mission bug
  • the ability to change display options at all and actually have the game able to re-start without re-setting to defaults or it crashes

other than those two things it runs “ok” out of the box with glorious eggrol 5.2 proton.

But for me is totally unplayable due to the watch monitor bug. I ran through the “fix” for installing codecs and either did it wrong or it doesn’t work.

yeah that’s the one, i haven’t tried many others but this one is pretty active pulling in the new changes from upstream so I pretty much default to it if the steams proton doesn’t work.

1 Like

Well deciding to give it a real shot and got it working under steam’s proton 5.0-5 and got past the “watch monitor mission bug” by installing the media foundation fix.

These are the steps i took to run/install the media foundation helper scripts, making the assumption that everything is installed under steams default library.

This IS written out like a script but you know… eye it properly make sure the paths and commands make sense to you before putting it in a terminal.

mkdir "$HOME/git"

cd "$HOME/git"
git clone https://github.com/z0z0z/mf-install.git
git clone https://github.com/z0z0z/mf-installcab.git

cd "$HOME/git/mf-install"
PATH="$HOME/.steam/steam/steamapps/common/Proton 5.0/dist/bin:$PATH" WINEPREFIX="$HOME/.steam/steam/steamapps/compatdata/397540/pfx" ./install-mf.sh

cd "$HOME/git/mf-installcab"
PROTON="$HOME/.steam/steam/steamapps/common/Proton 5.0" WINEPREFIX="$HOME/.steam/steam/steamapps/compatdata/397540/pfx" ./install-mf-64.sh -proton
cp mfplat.dll "$HOME/.steam/steam/steamapps/common/Borderlands 3/OakGame/Binaries/Win64/mfplat.dll"
1 Like

Hi FONFON, following protondb page, I managed to install ge-custom, as HWE, I already had it on m y pc before posting here. There must be something pretty easy I am not perceiving.

Hi FONFON, I tried this too, even deleting pfx paste. I dont get any screen from the game. I hit start, It manages to install some component and then nothing changes on the screen.

*I hit play.

Yeah, none of my stuff is installed under steam’s default location (Steam library split across 2 SSDs plus ~/.steam, so i’ll need to figure it out.

But thanks, at least that’s confirmation that it works with proton 5.0.2 and you got it working, cheers.

My situation is wierd, i get videos to play except for the monitor watching. Maybe its because i have some sort of state saved from before i installed the codecs, but i did try starting a new game twice and got the same result. Doesn’t help that i don’t know what’s video and whats rendered too, i guess.

But thanks again :slight_smile:

@adrianosousa, I believe what you’re experiencing that its probably bl3 defaulting to the dx12 engine if I’m not mistaken (its pretty much the only time I’ve had the game exit out on me in the way you described) but i think its now the default if the game thinks you can run it. Within the steam library in which you have bl3 installed look for “steamapps/compatdata/397540/pfx/drive_c/users/steamuser/My Documents/My Games/Borderlands 3/Saved/Config/WindowsNoEditor/GameUserSettings.ini” there should be a option “PreferredGraphicsAPI” make sure its set to “DX11” and not “DX12” (I have noticed that the configs for the game goes a bit all over the place and may be in a different directory)

I did get the bug as well as you before the media foundation stuff, probably the best tell that i can give you if everything is setup right is that there’s a couple of logo videos that play when you first launch the game if you don’t get a little gearbox video intro that has a child’s voice saying the words “GEARBOX!” then its media foundation related.

1 Like

@FONFON, When I try to reach …/My Games folder, there is no Borderlands 3 folder. Strange isn’t? Just tried reinstalling the game and Proton 5, and the mf dll files, nothing changed, the game still doesn’t launch. And obviously, i tried again with Proton 5.2GE.

That is quite strange do you even get a splash screen when launching? If it’s not even getting that far my only real guess is that your graphical stack (drivers) might be outdated or your missing some core library that is expecting to be there. You could try launching steam from a terminal so you can see it’s output but also check your home directory and see if steam dumping log files there, maybe you could glean something.
I’m afraid I’m only really guessing at this point.

Thanks heaps for that i got it sorted. For some reason steam wouldn’t install the proton 5.0.5 prefix where you put it, but i ended up figuring out where Glorious Eggroll 5.2 was and tweaked your instructions to install there.

Plays well.

Definitely want to select DX11 though, way smoother at least with Vega 64. I’m playing in 4k pretty smoothly - smoother than BL2 seems to be in terms of aiming and movement anyway. :slight_smile:

At times I’m a little shocked on just how well dxvk runs, I really wish valkan existed and drivers was where it is now when steam first started pushing linux support. Seeing the performance from ferals shadow of the tomb raider port literally had me spinning in my chair with glee.
Anyway glad things are working for ya.

1 Like

Thank you very much, I updated the kernel (to 5.5.9, I knew it was something simple), the game launches and runs out of the box!