Booting back into Linux [solved]

Earlier today I was trying to get Windows (7-10) on an old WD Blue 250Gb drive that I have so I could play Battlefield 4. That is the only thing I need the OS for, so an Old drive would do. I have several .iso of Windows and I created a boot Usb with unetboot but it never came up to boot Windows. I went as far as disconnecting my Linux boot drive and trying to install it on the 250GB WD Blue, ( I did not disconnect my RAID0 or my 3TB WD Black, too much work ) but I got a grub prompt. So I reconnected my Linux drive back, restarted the machine and the grub prompt came back up. I restarted again, but spamming F8, I chose the Linux SSD and booted back into Linux with all my drives attached and no problems.

The issue is, I want to be able to boot like before, without having to spam F8 all the time. Is there something I could do to fix that? I would assume its a grub2 issue, but I don't want to go further without advice.

System Specs:
Asus Z97-A | i5 4690k | Samsung 850EVO 250GB (Fedora 23 4.3.5 kernel) | 2x 1TB WD Blue RAID0 ( /home ) | 1 3TB WD Black ( ~/Wing-Man ) | 1 250GB WD Blue (Archiver) |
.
.
.
.
P.S : I know the whole "Google it" "DuckDuck Go for It" but this is a community, and sometimes "How you ask the questions" gets you different results. If this post is irrelevant/breaks community guidelines, then the mods will take it down.

Thanks

I am not sure this will fix your problem, but I think you need to update grub.

It should be as simple as sudo update-grub

Hopefully that will find the missing windows boot manager and allow you to boot to windows from grub : )

2 Likes

As far as I know that command only works in Ubuntu or Debian based distributions. You'd have to use grub2-mkconfig in order to update it. I could be wrong, though.

Also, make sure you have osprober installed. Without it, Grub won't find Windows.

1 Like

Ah see, those are the only two distros where grub did not automatically do its job.

I never figured out why grub seems to work better on some distros than anothers.

1 Like

Haha, update-grub is practically an alias for grub2-mkconfig. It's apparently a script with these contents:

#!/bin/sh
set -e
exec grub-mkconfig -o /boot/grub/grub.cfg "[email protected]"

In other words, that's not a native Grub executable, it's something packaged with the distro. I guess it also depends what comes pre-installed. I would expect os-prober to come by default on Fedora.

1 Like

This worked ! Ive had a long day so it took me a minute.

grub2-mkconfig --output=/boot/grub2/grub.cfg

Thanks to @Tjj226_Angel & @Jeol

MODs please mark as SOLVED

2 Likes

Good to see it working.

did you get it to detect Windows?

Nope. I left it alone for now. I just wanted to play BF4 and Warframe. But I should just focus on Pyhton and Bash scripting ! Lol