Boot/USB3.0 problems

So I just finished building my rig and I'm having problems when I plug in my mouse to my USB 3.0 port. I installed all the drivers for the motherboard and the USB 3.0 connection either fails on me or becomes really flaky.  Also sometimes the boot gets stuck on the windows logo if my mouse is plugged in.  I even tried installing drivers from the disc that came with my motherboard and it still doesn't work. By the way my specs are


Asrock Extreme 4 z77 mobo

Intel core i5 3570k

8gb of g.skill ripjaws ddr3 1600MHz ram 

650w psu

1tb hdd

60gb ssd

Radeon 7870 core edition

Asus disc drive

Any help would be greatly appreciated. THX


Might want to plug your mouse into a usb 2.0 port instead, more compatible 

I still want to make use of my USB 3.0 ports though, still have a coupIe other peripherals

Update: just realized that when Iplugged and unplug from my ports the ports all together stop working


Might be a faulty board. I would do an RMA or call then to troubleshoot the problem

It's only happening when I use my mouse.  Not my keyboard or Xbox controller


It's only happening with my mouse


then that might be the mouses fault

I just tested it out on mylaptop and seams to work fine


Also it's not letting me shut down when the ports freeze up

Also it's not letting me shut down when the ports freeze up


(I am not responsible for any damage caused)

Is there a bios updates on your board? Did you personally install the latest drivers because sometimes MS only istalls its default driver sets. Not the ones the manufacturer of the chips recommends.


I looked up your board and it has a lot of bios updates (if I looked up the correct one). Are you running 2.00 because some of the earlier updates have usb fixes in them(which will be included in the latest bios version also. Try updating your bios to the latest version and see if that helps. If you don't know how to update your bios read carefully before attempting as a bad bios flash can ruin a board.

Go to the actual ASrock site for the downloads.