Boot loop QEMU KVM nVidia GTX 1080 & Win10||Win7

After installing drivers in VM windows goes into boot loop. Any good ideas

Linux: Ubuntu Mate, Kernel 4.12

EDIT:

VM works fine with AMD GPU

QEMU CMD

[email protected]:~/vms$ qemu-system-x86_64 -version
QEMU emulator version 2.8.0(Debian 1:2.8+dfsg-3ubuntu2.2)
Copyright (c) 2003-2016 Fabrice Bellard and the QEMU Project develo

qemu-system-x86_64 -name SVM1 -enable-kvm -machine type=q35,accel=kvm \
-drive if=pflash,format=raw,readonly,file=OVMF_CODE.fd \
-drive if=pflash,format=raw,file=OVMF_VARS.fd \
-cpu host,kvm=off,hv_time,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff,hv_vendor_id=123456789ab \
-smp sockets=1,cores=6 \
-m 8192 -mem-prealloc -balloon none \
-device vfio-pci,host=25:00.0,multifunction=on \
-device vfio-pci,host=25:00.1 \
-usb -usbdevice host:046d:c52e \
-net nic,model=virtio -net bridge,br=br1 \
-device virtio-blk-pci,drive=device_blk_one -drive file=win10.img,format=qcow2,if=none,cache=writeback,id=device_blk_one \
-device ide-cd,drive=device_blk_two,bus=ide.0 -drive file=Windows10.iso,readonly,if=none,id=device_blk_two \
-drive file=virtio-win-0.1.126.iso,readonly,if=none,id=isocd -device ide-cd,drive=isocd \
-monitor stdio \
-display none \
-vga none

-

/etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="iommu=1 amd_iommu=on rd.driver.pre=vfio-pci"

[email protected]:~/vms$ cat /etc/modprobe.d/vfio.conf 
options vfio-pci ids=10de:1b80,10de:10f0,1002:68bf,1002:aa58
options vfio-pci disable_vga=1

-

[email protected]:~/vms$ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored

kvm
kvm_amd
vfio
vfio_iommu_type1
vfio_pci
vfio_virqfd
virtio-pci
virtio-net
virtio-blk
virtio-balloon
virtio-ring
virtio

-

Host CPU: AMD Ryzen 1700X
Host MB: MSI X370 GAMING PRO CARBON [Bios: 1.7, AGESA Code 1.0.0.6 ]

Does it throw any errors? Maybe the Error 43 issue with the nvidia driver?

No blue-screen, i can only see windows loading logo and boom restart. Error 43 does not make windows go restart loop, error 43 just does not allow driver to start at all. Its something else, i have started vm successfully with my amd fx platform but not with ryzen.

Did you reinstall that VM or just tried to boot it after the CPU change? Because I had that happen on a physical machine when I just updated a BIOS years ago :confused:

host cpu same no change, i got vm working few months ago on my FX platform but performance was crap :slight_smile:

Ah ok misunderstood that then :slight_smile:

Pretty much out of ideas :frowning:

work around is related to Error code 43. Google yeah you funny :smile:

As dumb as it might sound I'd create a new VM (leaving the old one intact if you have the space) using the Nividia GPU from the get-go, new fresh install of Windows with the work-around for the error 43 you will get when you load the Nividia drivers, I'm guessing the problem is in your Windows install not the VM or the GPU, this could be especially true if your running Win X in your VM.

Just a option.

Tried Win10 and Win7

> Added some more info into original post!