Bluetooth won't bluetooth

I have tried 2 diferent bluetooth dongles and neither is working. I followed the guide for getting the DS3 to work on PC and I bought the exact same Kinivo dongle in the video and the damn drivers wont install. It won't detect the dongle. The first dongle didn't light up at all and this one started bright when I plugged it in and now it is alot darker. I have no idea what I am doing wrong the software from broadcom wont detect it and the cd that came with the dongle won't either. HELP!

Have you tried a different usb port?

I tried both usb 3 ports in the front and also in the back. the light turns on but the installer still doesnt detect it. the light inside used to be brighter when i first plugged it in but it has since gone very dark. it is still visible though

So, you've downloaded and installed the drivers from the manufacturer's website then I take it?  Does the bluetooth adapter show up in your device manager, or is there nothing?  If it's there and just not working, make sure your bluetooth service is set to automatic (Run>services.msc).  If the bluetooth adapter is not listed in device manager, then try it on another computer (preferably one running a different operating system) to see if it's a dongle issue, or a problem with your computer.  That should help you narrow things down.

have you tried primer before paint? 

I have tried to install the drivers software from the disc that came with the adapter and also the generic software from broadcom's website and neither can detect the bluetooth device as being plugged in, so i cant install it without it being detected by the software first. no matter what usb port i use. I have plugged other stuff in and it detects just fine in the same ports (i plugged in my ds3 controller and it already has ds3 drivers working I just want it to be wireless now)

Never bother with the disk.  9 times out of 10 it contains grossly outdated drivers/software.  The broadcom software works a lot of the time, but it's not perfect.  Go to Kinivo's website and download the latest drivers for your operating system.  Install those and see if it helps.  

The reason I suggested trying it on another computer was to see if your computer/OS had an issue with that specific dongle, not to see if it had an issue detecting peripherals in general.  So it's still a good idea to check that if the drivers from Kinivo don't work.  If you get nothing on that computer as well, return it and buy a different brand dongle, since you seem to be having no luck with Kinivo.

Edit:  I just checked and Kinivo seems to use Broadcom drivers.  So you may be out of luck there.  Either way, try redownloading them and see if it helps:

Also, follow these directions when installing everything, if you haven't already:

Yeah I got the same problems when I tried to install the iogear adapter I had before. I am using the bt4.0 version. maybe I should just go with the bt3.0 adapter