Return to Level1Techs.com

Bluetooth Issue: X570 I Aorus Pro Wifi (Debian 10 - testing)

Hey everyone, I decided to switch from a Mac to Linux, so recently I built a PC for web development. Everything is all well, but there’s this one issue that’s really annoying:

  1. Bluetooth will not work or be detected unless it’s booted on windows first.
  2. Once, it’s booted back to debian, Bluetooth works flawlessly on all devices except for bluetooth headphones/speakers

**What I’ve tried to resolve #1

  • tweaked the bios (anything related to usb/network) non of it worked.
  • installed the latest driver from intel
  • tried troubleshooting guides i can find

non of the above helped, so I’m okay to live with booting to Windows then Debian.

Steps I do to resolve issue #2

Bluetooth headphones (Sony WH-1000XM3) connects as expected but only works as mono so, here’s what I do:

  • restart bluetooth service with sudo systemctl restart bluetooth
  • connect the headphones again
  • manually switch from hsp/hfp to a2dp sink
  • run the test for changes to take effect

if i’m Iucky, it works flawless from there, sometimes it doesn’t and I have to go through the whole process.

Here is my Hardware Probe I’d appreciate any kind of help.

I really like Debian and would like to keep using it and support Linux by using it, I have lots of patience, but sometimes it gets really annoying but it’s too late to regret now :grin: :grin: help?

The issue is not GNU/Linux but more than likely the vendor’s implementation or quirks in their hardware. Vendor rarely stick to the actual specifications.
Try looking at the Gentoo or Arch wiki for help. I use Arch and Debian daily so I may be able to help here.

Example.
https://wiki.archlinux.org/index.php/Bluetooth#Troubleshooting

Thanks for response @Mastic_Warrior . I lived with the same process for about a month since it’s just a case of firmware maturity and/or development. as of these firmware revisions:

the issue has been fixed, and can easily be updated by adding the non-free to sources.list

## sources.list
deb http://ftp.fr.debian.org/debian bullseye main contrib non-free

## and manually update it, to confirm whether it's working as expected 
## try to completely shut down the computer, and turn it back on again.
sudo apt update && sudo apt install firmware-iwlwifi