Blue Yeti Pro extremely low recording level problem

I'm having problems with my recently acquired Blue Yeti Pro microphone to the point that I am wondering if it was damaged in shipping.

The recording levels in all modes (omni, stereo, cardioïde, etc) are so low that to hear anything you have to jack the gain up so load that you have almost as much white noise as you have actual desired sounds being recorded.

Any information, or insight into this would be greatly appreciated!

What works :
The drivers install correctly and the devices shows up in Device Manager.
I can use Audacity/Adobe Audition to record sound (really cruddy sound).
The Yeti Pro Control Panel shows in my taskbar.
I can use the microphone jack on the Yeti Pro to listen to audio from my PC, and use it to monitor the sound heard by the Yeti Pro (the really cruddy sound, and you have to have gain and headphone knobs practically full).

What doesn't work :
Recording good quality sound with a respectable noise level.

What I have tried :
Using a different USB port (USB 3.0 and 2).
All the various settings on the mic itself.
Using generic Microsoft USB Microphone drivers, and the Blue Yeti Pro Drivers.
Changing Level settings for the mic and outputs in Windows.
Changing Input/Output levels in the Yeti Pro Control Panel.

What I haven't tried (because I can't) :
A previous version of Windows.

My setup :
CPU - Intel Core i5-4690
Motherboard - Gigabyte GA-Z97X-UD3H
RAM - 16GB 2133MHz
GPU - Windforce GTX 970
Case - Corsair Obsidian 550D
Storage - SanDisk 960GB SSD + Seagate 2TB HDD
PSU - Lepa B650
Display(s) - 3 x Samsung SyncMaster
Keyboard - Corsair RGB K70 MXRed
Mouse - Logitech G602
Sound - Alesis M1Active 520USB
Operating - System Windows 10 Build 10586

Additionnel info : I have already used a non "Pro" USB Yeti mic for recordings so I know how that version handles. In this state, even at full gain, for levels all across the board, it isn't even possible to hear my voice from 50cm away in a Skype conversation.

sounds like a issue with the blue yeti pro itself. maybe ask for a replacement model.

Thanks for your reply, it's what I thought too. So I've asked for a replacement and I'll post here in a couple of days if the new one works fine :)

1 Like