Blue light filter fine tuning in Linux

In Windows 10 under Settings app, System, Night LIght settings, there is a slider that allows fine tuning adjustments of the blue light filter.

I’ve tried Redshift and also some kind of under deal with it ( I don’t remember at this moment what it was), but I could never get it ( be it Ubuntu 18.04 vanilla, mate, or Mint 19 cinnamon 64 bit) to go anywhere in between…off and ultra freaking redish orange…too damn red and orange.

Please help? I have no problem uninstalling whatever to follow your experienced and proven true instructions. Thank you

You should be able to edit the colour temperature in the Redshift config file.

1 Like

You can make a redshift.conf file to set the color temperature manually. There is a sample file on the website of the guy who made it. That’s what I use on all of my PC’s.

1 Like

I didn’t even know there was a config file ( facepalm). After reading your comment and doing some further search though, I stumbled across this

Paul Chris Jones’s idea ( which seems like just typing without quotes redshift -O whatevernumber" and it might give me precisely what I want. Then I think perhaps I could add that as a custom command to autorun when I boot into my Mint destkop.

I’ll respond back for whatever ideas work.

I run redshift on mint. You can put all the parameters you want in the command-line arguments, but if you want to turn it off and on again later (to play a game, watch a movie, whatever…), you’ll have to remember all the options. It’s a lot easier to put your preferred defaults in the config file imo, you just have to type redshift in the cli or run the gtk widget.

My config file is ~/.config/redshift.conf:


There are other options—you can change the gamma and hardcode your location iirc. Probably all possible options work as command-line args as well, but a config file makes more sense.

I just added redshift-gtk as a startup item with a delay of a few seconds. I think the location service bombs out sometimes if you run it immediately after logging in, and it doesn’t work for the login screen.

1 Like

Awesome info. I’ll try that also and report back. Thank you :smiley: