Return to

Black screen from gpu in slot 1 on windows vm

Hi all,
I’ve got an x299 system with gtx 1080 ti in first pcie slot and a gt 1030 in slot 2.
I’m able to successfully pass through either gpu without problem. Nice iommu on x299 helps.
Had no problems installing drivers for the gt 1030 and using it in a windows 10 vm.

When I use the gt 1030 on host and gtx 1080 ti on guest I get a black screen after driver install. The vm is still running and I can move my mouse around my monitors and spice display but thats it.

I tried giving a patched vbios to the vm but it did not make a difference. I’m not sure what I should try next?

Heres my virt-manager xml. Its just got the usual fixes to hide the vm from nvidia drivers.
Pastebin 4vgyrejb

I managed to get this working.

Looks like I was sort of barking up the wrong tree with the Nvidia rom patcher. The win10 guest can actually use the 1080 ti in the first slot without a patched vbios. I just needed to set kernel parameter video=vesafb:off,efifb:off