Black lock screen on fedora 21.. Please help

Alright. So i'll make this as clear as possible.

I recently had problems with fedora 21 where the boot menu would show up. I'd select which version of fedora i wanted to use and then i would be greeted by a black screen where the lock screen should be. I can't acces any form of command line either so i was stumped. And after reading through tons of threads online i did not get any wiser..

So i did what any desperate man would do. i fappe..Ehm I re-installed fedora. Forsaking any of the files i had on my previous installation. And after updating, installing the gnome tweak tool, yum extender, gnome shell extensions, enabled rpmfusion, updated again, vlc, fastest mirror plugin, flash player, chrome, fedy tool, virtualbox, gnome music player, And the driver that worked the last few times which was the "newer geforce" drivers from the rpmfusion site.
Then i watched some youtube videos and hung around on some forums before turning my pc off.
.. The problem is back.. I can press c to bring up some form of command line in the boot menu but thats about it.

Any suggestions as to how to fix this.
Or if you noticed a major screwup Salutes that would cause this. Feel free to point it out to me..
I was just playing a game on windows and it auto updated.. I need to get back to linux!

Edit: forgot to add specs
cpu: 3770k
motherboard: asrock pro4
gpu: asus 780 strix

Thanks in advance.

Did you disable KMS with 'nomodeset' & 'nouveau.modeset=0' in the kernel parameters?

Nope. I've been using linux for the last year without any problems so i haven't really messed with it too much :/

How would i go about doing this?

What nvidia drivers are you using?

if binary you need to add the nouveau.modeset=0 line to grub.

adding nomodeset in grub as it boots will let you boot up. interupt grub at startup (any key) and press e to edit, edit the kernel line and press f10 to boot. then fix your drivers.

Open /etc/default/grub as root with a text editor

Append 'nomodeset nouveau.modeset=0' to the GRUB_CMDLINE_LINUX_DEFAULT= line
(a space seperates the parameters)

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset nouveau.modeset=0 something something"

EDIT: Oh, and remember to update grub
EDIT2: Typo'd 'noveau', it's supposed to be 'nouveau'

I followed a guide on the Rpmfusion site. it just said "Newer geforce"

When i tried your solution it resulted in a "kernel panic" unable to mount rootfs