Bizarre PC boot issue

Greetings all. This issue is a bit of a weird one.

I’ve started having a significant issue with my unRAID server.

Basically it’s stuck in a boot loop, it gets to around the same point when loading the OS then hard resets, and starts again, (no error, just a hard crash). I tested installing Windows and that also crashed early in the process.

I’ve tried a different power supply - same thing happened. I tried installing onto different media - booting from live USBs and am not able to get them to load. I removed all four RAM sticks and tried just one - that also failed, I tried a different RAM stick and it also failed. I removed all other unnecessary components - also failed. I reseated the motherboard and all components multiple times. I’ve also updated the BIOS to the latest version, didn’t help.

I can only get it to load when I remove the 3900X and put in a 3700X from my gaming PC. Naturally I then assumed the problem was with the 3900X CPU, however I am able to run the 3900X in my gaming PC without any issues. I ran Prime95 for about 30 minutes and tried gaming for a bit with it - ran fine with no issues, however as soon as I put it back in the motherboard below (with no other changes) it just keeps hard resetting when loading unRAID. I can replicate it 100% of the time when I change nothing other than the CPU - the 3700X (that was in my gaming PC) works great, the 3900X doesn’t load. My 3900X is also only a couple of months old - I got it and my X570 board at the same time.

So then I was convinced that it’s a motherboard issue, no problem, it’s only a couple of months old - I’ll just RMA it and get a new one. Well I’ve just got the new motherboard (Strix X570 E) and the same thing is happening on this brand new motherboard. It’s so frustrating.

Now I’m back to thinking that the CPU is at fault, even though it works fine in my little MSI B450 ITX motherboard. I can’t think of anything else that it could be. Can anyone provide any insight?

Stock clocks?, you try usb ports that are off the chipset not the cpu?

Yep stock clocks, I’m not sure that it’s a USB issue as if I change out ONLY the CPU it works fine, without changing any USB ports. That’s when I thought it must be a CPU issue, but the 3900X that won’t boot works fine in my B450 motherboard.

It’s like there’s a fault with the CPU that is causing issues with the X570 board, but not the B450 board.

The are usb ports that are off the cpu and ports that come off the chipset. I would imagine you arent booting off usb on the other computer the 3900x works on correct?

Even if I try booting Windows from a SATA hard drive the issue still occurs - crashes when loading into Windows. It crashes at different points of it starting up.

The one from the known good system (your gaming rig?)

Yep Corsair SFX 600W.

how fast do you have your ram set to, your 3900X might have a mem controller/infinity fabric that can’t handle it

So Verfied parts

PSU (One from gaming rig works with cpu in that mobo)
Mobo (swapped via RMA)
Storage (swapped a bit tried live boot and other things)

Bio reflash / update (Doubt but possible)

RAM was set to 3000 (XMP speed of the RAM). But have also tried the stock ~2133 Mhz as I didn’t set the XMP profile on this new replacement motherboard. I’ve just lowered the RAM speed (single memory module) down to DDR4 - still crashing.

I can’t see how it’s memory or GPU or BIOS if when I switch out the 3900X for the 3700X it magically works, but I have a PCIE x 1 GPU with display out that I’ll test. BIOS on the old motherboard was flashed to the latest version (after the issue start happening). BIOS on the new motherboard is probably a bit out of date.

I’ve done a memtest as well - tested fine with no issues. I originally had four RAM sticks in there, but I’ve just been testing with one for the most part - switching out that one stick with the others to ensure it’s not a single DIMM that’s faulty.

did they prehaps just send your old board back or was it crossshipped

I’ve triple checked that - it’s a different serial number, with the clear plastic film over parts of the motherboard. Also the NVME SSD pads were brand new so I’m certain it’s a new board.

Motherboard is still crashing with different GPU.

do you have above 4G decoding turned on, try turning it off if it is
force PCI-E gen 3?
disable fast boot

I don’t think I have an option for above 4G decoding, or I haven’t been able to find it at least.
Fast boot is disabed.
Just went through and switched everything I could to gen 3 PCIE, has crashed again.

the 1700$ intel asus mobo had a cold bug, I don’t think it has it but hey this has me stumped

have you changed heatsinks at all, like did you use the 3700X heatsink on the asus board when you swapped, might be a heatsink issue

I used the same heatsink on both the 3700X and the 3900X.

It really is a bizzare issue, I’m thinking of just RMA’ing the CPU back to AMD, the question is do I tell them that it’s booting in another AMD motherboard? Do they test the CPUs that get sent back or just straight replace them. I’m worried they will test it and it’ll work in their board but (all of a sudden) now doesn’t in mine.

if worst comes to worst, its not a “solution” more of a “hotfix”
but swap CPUs in both boards where they work in, then swap your Gaming Pcs Mobo with your Unraid mobo
use your unraid mobo with 3700X in your Gaming PC
use your Gaming mobo with the 3900X in your Unraid PC

My B450 board is ITX (along with an ITX case), it only has one PCIE slot. So I can’t swap boards in my PCs as I have three PCIE devices in my X570 board, but I can swap out the CPUs to get it back up and running until I (hopefully) send the 3900X back to AMD and get it replaced.

Thanks for your help anyway.

There have been over a DOZEN uefi releases for this motherboard. (I should know, I’ve got a similar x570 TUF) Strix-E’s latest 2607 was released two weeks ago on the ASUS website include an AGESA update. I know at times its to support upcoming processor launches, in my x570; resolving a FireWire PCIe issue with Texas Instrument chipset.

Initially, I recommend using the 3700x to update the BIOS.
Next, use the DDR4 memory from ITX board + 3900x give it a whirl with the Strix.

Update - got new 3900X from AMD after sending my old one back. Chucked her in and we’re rocking.
Very weird issue, but the CPU was clearly at fault, even though it worked in my B450 board!