Return to Level1Techs.com

Bizarre issue with random reboots while using Linux Mint but not Windows

So this all started when I decided I’m going to make the move on my primary desktop computer away from Windows over to Linux, I have been using Linux on all my over computers for a while now. Before I wipe my Windows install and be without a functional gaming PC, I decided that I would install onto a 2nd hard drive to verify that everything is working. And I’m glad I did that because things are going horribly wrong…

At first, I was having trouble getting the installer flash drive for Linux Mint to boot in uefi mode without CSM, but then I forgot I had fastboot enabled. After disabling that, I was able to install to the 2nd hard drive and boot into Linux. However, after the first reboot from running some updates and installing the Nvidia graphics drivers, the system was getting to the Linux Mint splash boot screen then shuts off with no warning, and reboots. Right now, it does this most of the time when I reboot, but sometimes it doesn’t happen. After a few tries of booting it would eventual boot up, and for the most part there aren’t any issues after a successful boot, however occasionally I have logged in and clicked an icon on the desktop or just using firefox and had it abruptly shut down like it was doing at start-up.

But here’s the thing: I can boot windows off my SSD just fine, even running games and stress tests work fine. Because of this, I know its not overheating or having power supply issues, but this seems too random to be a software issue. I edited the GRUB settings to disable the splash screen so I can see what it’s doing when it is starting up, and every time it “crashes” it’s doing something different, I can’t identify any pattern. The logs program in Linux Mint doesn’t show any fatal errors that would cause a reboot. I’m not new to linux, but I have no idea what could be causing this or where to look to find out.

Like I said before, I am using Linux Mint. I am currently trying other distributions on this machine as a troubleshooting step and will report my findings back here when I can. I also tried resetting my BIOS settings with no change, and may try a different drive even though this drive’s SMART status is perfect. Here are my system specs if it helps:
-Intel Core i5 6600k overclocked to 4.4GHz at 1.280v (I have done overnight prime95 runs on it with no issues, and running it stock didn’t change anything)
-EVGA GTX 1060 6g
-Asus z170-e
-Intel HD Graphics is enabled in the BIOS for setting up a Windows VM with KVM
-4x4gb DDR4 2133mhz (tried with and without the XMP profile made no difference)
-500gb WD blue M.2 SSD (the older model that is sata over M.2 instead of PCIe) for my Windows Drive.

-Some random Toshiba 1tb 5400rpm I pulled from an external enclosure for testing Linux and installed in the PC

-A Renesas 4 port usb 3.0 card

I also tried installing Linux Mint in CSM Legacy mode and now it doesn’t have issues booting but it still occasionally shuts off while using programs.

A few things that currently come to mind.
Maybe there is an issue with the said HDD you installed Mint on.
What you could try to do, if you have a spare drive laying around,
and try to install mint on that.
But I see that you already tried that if i’m not mistaking?

Another thing to try, like you pointed out yourself try a different linux distro.
If you are new to linux, maybe you could try something like Ubuntu Mate 20.04.
But based on your hardware, i suppose that Mint should work perfectly fine on that.
But yeah Nvidia drivers can be a bit fiddly.
So maybe it could be a driver related issue as well.

Which version of Linux mint are you running?
The regular 19.03, or the LMde?
And which kernel.

Maybe some of the more advanced linux guys,
could also jump in with some idea’s. :slight_smile:

Like @MisteryAngel mentions, you could try to rule out two suspect causes, the graphics card driver and the hdd. I’d remove the GPU and run off of the IGPU, and try installing on another medium.

You say you’ve looked at the boot screen, but it actually puts it in logs. Have a go at this article and report back what you find in journalctl and /var/log/boot.log for instance.

https://www.tecmint.com/find-and-fix-linux-boot-issues/amp/

Thank you for the replies! I would try a different HDD but I found that my only spare HDD is now dead. I’m not sure this is the issue though, I just tried normal ubuntu’s installer on a flash drive and it doesn’t even start up, reboots immediately after I click ubuntu at the grub menu, but only when I’m using UEFI mode. CSM mode works like mint did but still has random restarts. I will try to source another drive, but I would rather not wipe my windows install if I may have issues, I have backups and everything but I don’t want be without a functional gaming pc for a while. I also tried removing the GPU from the system and trying different driver versions, none of that made any difference. I will try looking though the logs @Zumps mentions again, but I remember looking there before and not finding anything.

UPDATE: Nothing in the logs besides file system correction from the abrupt shutdown that happened before that boot.

I was testing with Linux mint 19.3 (the ubuntu based one, not the debian one) with kernel 5.3.0

First thing I would do is completely turn off C-states. Do this in both BIOS and with kernel boot arguments in Grub.

1 Like

Just tried this, both in BIOS and GRUB as well as turning off some of the power management features and none of it made linux boot consistently. I’m not sure if I mentioned this before, but this weird behavior also exists when booting the installer flash drives for any linux distribution i have tried, not just after an install. In fact when I am able to get the installer to boot, I have had it reboot on me during the install several times.

The oddity with USB installers is Nouveau. You need to disable nouveau on install to retain stability. You also need to immediately go to the proprietary drivers while starting nomodeset.

Even if I am able to get the installer to finish and enable the nvidia proprietary drivers, i still have these issues. nomodeset doesn’t seem to make a difference unfortunately. Because in ubuntu if I try to boot in Legacy CSM mode it shuts the system off within 3 seconds of booting from the installer flash drive, I’m not convinced this is a graphics driver issue.

The last thing is a BIOS oddity with the board. I’d suggest changing platforms at this point. That board may just have developed a quirk. I also can’t guarantee your OC will be recoverable with a BIOS update.

Yea, im starting to accept this as being the issue. The BIOS is on the latest version witch is from 2018, and i don’t think ASUS is going to send many more updates unless there’s another patchable security flaw or something. Well at least I was considering upgrading since my daily routine has begun to use more multi-threaded and CPU heavy applications, so I guess I won’t be switching to linux until I save up for that… Thank you anyways for your help!

quite often quirky installs can cause a plethora of headaches.
a large amount of the time it could be a faulty download, or hardware incompatibility.
when faced with a troubling install My method is to make a paper list of possibilities. and rule them out if they are not the case.

The problem most people have trouble understanding is Linux ships with universal drivers for most (But not all) hardware, and some manufacturers are in the micro-sith’s pocket and develop proprietary hardware that will only work on windows.

Most versions of linux can and will have issues with a drive if it is near its death!
while an install will go ok, if the drive gives off excessive heat you have a problem!
many cases have cramped spacing and little air flow between drives and heat can cause flaky operation in both spinning rust and quite often can cause catastrophic failure to an ssd. I’m a great believer in keeping the system cool.

and finally as linux evolves many of the 64 bit versions tend to be aggressive in cpu resources particularly with multitasking operations.
while a good gpu can remove some of the load it is not a cure all, and often many gpu’s do not support linux or require work arounds for their driver quirks.

Thanks for the reply, this is all good advice. Unfortunately I have done pretty much what you have said and have isolated the hardware until i’m left with the CPU/motherboard/RAM. All my drives seem fine, redownloaded multiple distros multiple times, but I just can’t get it to work right, even with the bare minimum hardware installed to get a POST and install with good airflow. I know for a fact that my CPU/motherboard/RAM are working fine in windows, but something about this config makes linux unhappy. I was planning an upgrade anyways, I may go ryzen if I can find any motherboards in stock that have a good linux reputation, so I think I’m going to cut my losses and go that route.

Again, appreciate the help!