Return to Level1Techs.com

Bizarre GPU behavior with me 5700XT

So I have had my Sapphire Nitro+ 5700XT for over a year, and I have never been sure it works like it’s supposed to.

Basically the gist of the issue seems to be that there is something wrong with it hardware wise that allows it to work flawlessly with DX11 games and programs, but act like it’s dying when trying to run anything involving DX12.

I’m no expert, so I’m not even sure this is possible. There was a point where after getting newer drivers installed, I was able to run DX12 titles for a while. Recently, however, I tried again to update the drivers to the newest ones only to get the 205 error that I was never able to resolve, despite trying everything I could find online.

I did manage to install newer than I had drivers though, which then gave me whole new issues. This time, in a way that contravenes the very purpose of the machine in the first place, playing VR games. All games through my Index now look way too dark and no amount of fiddling with settings will fix this.

So I just rolled back my machine to before I tried updating the drivers, when I thought it was able to play DX12 games. However, despite fixing the SteamVR issue, the inability to use DX12 remained.

Time Spy is just straight up dying GPU rainbow vomit when loading, and has artifacting when running.

I tried Shadow of the Tomb Raider in DX12 as well, and everything is way too blue, but it runs just fine and looks perfect in DX11.

The only thing I can think of other than a bizarrely dying GPU is my Windows 10 installation is either somewhat borked, or games, and video drivers just don’t like the LTSB build of Windows 10.

Any ideas on the issue or things to try that I haven’t thought of would be greatly appreciated.

Installing a fresh Windows 10 on a different SSD will give you answers to this.

This could well be the source of all things wrong here.

LTSB is NOT intended for gaming at all. It is a Long Term Support Branch. I am not sure to what extent but I vaguely remember it not getting DX12 support because it is not aimed at supporting that at all and they can do with out the added complexity.

1 Like

Trying this first, but man. M.2 SSDs have gotten me so spoiled. Having to install on on a machine that doesn’t uses SATA at all is a relative pain.

My other option is trying my 5600 XT I just have lying around. That might be the lazier solution here.

Oh my god, I think LTSB was the problem all along. I’ve been shooting myself in the foot for like 16 months. Both Time Spy and SotTR ran flawlessly in DX12.

How embarrassing to have something like that plague me for so long when it’s so easy to fix.

If any sort of problems arise this time, I’ll update the thread.

2 Likes

Glad it worked out!