Biky's autistic screechings and rants

It will.

Might need something to do initial setup until you get networking and ssh going,but my backup server is b450 mb and 2700x

2 Likes

Sweet, I had read that some boards wouldn’t post. Like I said I have a GT710 so thats not an issue. Im also going to try this NVME adapter to add some sata connections for ALL THE DRIVES lol. I have to take some measurements… going to try it in this COUGAR case QBX..

Something like this…

Ive mostly used asrock boards the past 4-5 years… so i cant speak for all brands

2 Likes

I just realized that the Level1Techs logo in the top left corner of the home page is stylized “LEVELONETECHS.” It almost looks as if the the name is a pun on “Leave (me) Alone Techs.”

Lev E Lone Techs → LE(a)EVE (m)E (a)LONE TECHS.

Even the pronunciation would be close to [Lee veel ohne teks]. Although the pronunciation is closer to “Live alone techs,” but that’s not as funny.

The even funnier part is that this could actually be plausible, as this channel was born by splitting from the “”“other channel,”"" presumably from a desire to be left alone.

1 Like

Or you know what would be even funnier? If this was a pun on “Leave me alone, Teks(yndicate).”

1 Like

I think you may be reading a little too much into it…

But it does kinda fit

2 Likes

Yeah, just felt like doing a sh*tpost theory.

2 Likes

it is your thread, and the screeching is kind of in then name, after all…

3 Likes

While this is somewhat related to SBCs / ARMLand, I wanted to keep that thread for stories regarding non-rpi boards. So I’ll use this opportunity to update this blog.

So, either something very wrong happened at alpine, or I did something wrong. And given that I have done literally nothing different this time as any other times, I would blame it on Alpine. So, what I did was to update the system, usual business, lbu commit, then reboot. But the system did not start up after 10 minutes. So I unplugged the pi 3, plugged the HDMI, powered it on… aaand…

/sysroot/etc/inittab no such file or directory
failed to execute /sbin/init

Check /sysroot/etc/inittab - it is there. Check /sbin/init, it is a symlink pointing to /sbin/busybox. Why 'dis not werking?! Type exit to continue booting - kernel panic. Oh, for fu-

So I spent the past hour or so without internet trying to fix this thing up. Thankfully I know how the alpine boot sequence works. All I had to do was rename the apkovl.tar.gz and the cache from my second partition and it allowed alpine to boot in a default state with no modifications. I tried updating a couple of times again, with an lbu commit and a reboot… and I always got kernel panics. Eventually after a bit of finagling and after some time passed, updating, lbu committing and rebooting, the board started normally.

I have 0 clue as to what happened, but I can pretty much guarantee that I dindu nuffin’.

Worst case scenario, I had a void-rpi3-musl image, albeit a bit old. Not sure if that thing would have worked, since Void changed from libressl to openssl and there were some other stuff happening that may not allow for a smooth transition. I tried upgrading a x86 VM with an older image just to see how well would Void stand the passage of time. It didn’t go well for me.

I’m glad I got this to work, but this outage was very annoying to say the least. Until now, I never had an alpine update go bad on me. I would still wholeheartedly recommend Alpine, but for my own use case, I may stop using it. Well, the plan was to move to an OpenBSD router eventually, but I’m still a bit far from there. I managed to get OpenBSD’s u-boot to boot it, but once it gets to it, it just goes to a black screen and the white activity LEDs on the rockpro64 don’t light up, meaning the OS doesn’t boot further. But at least I got it passed the original hurdle. Al I need to do now is partition a disk larger so that Ii can place the huge dtb on the vfat partition, so that u-boot can read it, because right now, it has no dtb there, which is what I am suspecting is the issue.

1 Like

Oh, the irony when visiting a webpage with an article talking about as little design as possible that doesn’t load without JS. Well, I suppose the design is a white page, but that’s just bad design.

1 Like

A few weeks ago I purged bash from my system. Things have been running well… until I tried running neofetch. Now I’m between a rock and a hard place: remove bash and have the feeling of being safer, or run neofetch… tough choice.

1 Like

Note for self when dmidecode -t 17 doesn’t show 72bit total width. In my case, it showed 128bit, which was ridiculous.

xbps-install -Su edac-utils lshw
edac-ctl --status
edac-ctl -vv
lshw -class memory | grep -i ecc

sample output:

biky-tr# edac-ctl --status
edac-ctl: drivers are loaded.

biky-tr# edac-util -vv
mc0: 0 Uncorrected Errors with no DIMM info
mc0: 0 Corrected Errors with no DIMM info
mc0: csrow2: 0 Uncorrected Errors
mc0: csrow2: mc#0csrow#2channel#0: 0 Corrected Errors
mc0: csrow2: mc#0csrow#2channel#1: 0 Corrected Errors
mc0: csrow3: 0 Uncorrected Errors
mc0: csrow3: mc#0csrow#3channel#0: 0 Corrected Errors
mc0: csrow3: mc#0csrow#3channel#1: 0 Corrected Errors
mc1: 0 Uncorrected Errors with no DIMM info
mc1: 0 Corrected Errors with no DIMM info
mc1: csrow2: 0 Uncorrected Errors
mc1: csrow2: mc#1csrow#2channel#0: 0 Corrected Errors
mc1: csrow2: mc#1csrow#2channel#1: 0 Corrected Errors
mc1: csrow3: 0 Uncorrected Errors
mc1: csrow3: mc#1csrow#3channel#0: 0 Corrected Errors
mc1: csrow3: mc#1csrow#3channel#1: 0 Corrected Errors
edac-util: No errors to report.

biky-tr# lshw -class memory |grep -i ecc
       capabilities: ecc
       configuration: errordetection=multi-bit-ecc
1 Like

I have just set up the TR system as a desktop. I don’t know if I’m doing anything wrong (very likely), but x86 is more unstable than aarch64. Sway crashes if I launch anything under xwayland. My terminal works because foot is wayland native. Firefox or st on the other hand crash sway immediately.

1 Like

Discovered that I was not in the video group on my new TR install. Sway was crashing because my user did not have privilege over my own dang GPU. The weird part was that only Xwayland was crashing. DRM leasing error gave it away thanks to a gitlab bug entry on freedesktop.

But it was a good experiment. I discovered that sway can run other desktop environments inside it. I literally ran sway inside sway, although I had to change the Mod key in the config, because the main one took priority.

1 Like

I am having way more fun than I should with virt-manager and zfs. I don’t remember this being so good. But now that it came to this, I will likely need to virtualize the linux system too. Host will be void-musl, VM will be void-glibc. Then I’ll add a windows VM. Need to install the 6600 xt and blacklist both drivers… So much to do…

1 Like

The past days I’ve been running test VMs on my TR system. It seems really fast, what can I say… I was trying to purge the system from desktop software, but in doing so, I managed to bork the virt-manager connection, something about polkit not existing. I could use the system without polkit before though. I wonder if something like dbus-x11 or dbus-elogind or seatd broke the authentication. virsh commands worked flawlessly, but I still need vnc consoles from time to time.

I migrated my prometheus+grafana VM here, but for some reason, it cannot detect its historical data. Well, there isn’t much left to begin with, but it is a shame. That VM was weird anyway, it would not boot with any kernel other than 5.9. I also moved a test openbsd VM and created a few void and a nix VM. Need to make a windows one soon, to grab some promotional garbage codes from AMD.

All that’s left is for my stupid NAS to get up and going, I need to migrate my final things over. It’s possible that before that happens, I may just grab 2 sata SSDs or HDDs and migrate the data on these. Having additional copies is not a bad thing anyway, but I’m kinda short on cash.