Behringer UM2 low microphone volume

HI L1T Forums, I’m having a problem with my microphone audio volume that I can’t seem to resolve. By default, the microphone volume is very low, to the point of being barely audible.
A quick rundown of my system:

  • Distro: Pop!_OS 20.04 LTS
  • CPU: Intel Xeon E5-1650 0 @ 3.2GHz
  • RAM: 32 GB of ECC DDR3
  • GPU: GTX 970
  • Audio Interface: Behringer U-PHORIA UM2
  • Microphone: Behringer Ultravoice XM8500
    I’ve tried looking around for solutions to this, but couldn’t find one that fits.
    I have tried:
  • Changing the microphone volume in PulseAudio with pavucontrol
  • Changing the microphone volume in alsamixer, but it lists the interface as not having any inputs.

Turning the microphone volume up in pavucontrol to 153% does help a bit, but it is still quiet in applications like Discord. I would try to increase the gain on the device itself, but that would increase the noise floor, and increase the chance of me clipping.

Just to sanity check a few things, have you listened to the mic through the direct monitoring on the UM2 to see if it is at correct volume at the interface itself.

And have you tried a known volume line in source to the interface to make sure it is accepting volume correctly.

Yes, the microphone level is the same as I had it in Windows. I’ve tried to play my phone’s audio with the Instrument Input 2. I’ve noticed that, when it’s clipping (or near clipping), it only goes up about half way on pavucontrol’s volume meter.