Return to Level1Techs.com

Before i install freenas

hey guys i have a home server i setup a few years back with mythtv, at the time its main purpose was to have a tv backend for the house. i ended up adding zfs to that for use of a file server.

now i don’t do the tv stuff anymore and would like to move to something like freenas. but i have a few things i need to ask before i make the switch.

1st i have a raidz2 setup and one of the drives has failed, should i replace that drive before i make the switch or after.

2nd i want to start saving all games on the nas what kind of shares should i set up? i have to many kids with to many games! also if i do this, can 2 of us can play the same game at the same time?

Always replace as soon as possible

What are the end clients running? Assuming the game is drm free you should be able to both play it.

1 Like

pretty much windows

NFS share it is then

awesome! it’s been so long since i have had to mess with ZFS how do i go about replacing that failed drive

Honestly its best to learn / figure out that stuff yourself and ask us if this command makes sense if you are concerned about breaking it. If you cant figure it out we can help but you wont learn nearly as much.

2 Likes

ok it seems i just need to run the command zpool replace once i put the new drive in. zfspool

1 Like

I’m curious what would happen if you replaced the bad disk with a modern (i.e. 4k sector size) disk since it looks like those have a sector size of 512.

ok i’m having a hard time i think i don’t know what disk, but who knows. this is what i tried
sudo zpool replace NAS1 /dev/disk/by-id/ata-WL2000GSA6472E_WOL240358767

it says it cant resolve path

just tried this
sudo zpool replace NAS1 sde

and got this
invalid vdev specification
use ‘-f’ to override the following errors:
/dev/sde does not contain an EFI label but it may contain partition
information in the MBR.

Don’t you need like both disks in the instruction?
and it might check the /dev/disk/by-id/ bit, so just the bit afterwards? (ata-)

And props for using the by-id, rather than the /dev/sdX which changes

ok so just this WL2000GSA6472E_WOL240358767 ?

then the ID of the new disk?

it seemed in all the docs if the drive was in the same place i only needed the one

huh.
I thought it went something like
zpool replace poolname old_device new_device

and you’d need to include the ata- bit, so

sudo zpool -n -v replace poolname ata-wdcearx20000-asdjksajd ata-wdceard2000-jaksdjkjj

but I don’t remember if old device then new, or new then old.
-v and -n should just show what will happen, without actually changing it. [edited in replace to command]

ok but what if the old drive is already removed

then you would use the removed [edit: the number matching the drive that is no longer in/working] ata-wl2000GSA… or 1844925148148087666 placeholdernumber. Either or should work.

ok ill try that, thank you btw

1 Like

this what i got

sudo zpool remove NAS1 1844925148148087666

cannot remove 1844925148148087666: only inactive hot spares, cache, top-level, or log devices can be removed

That’s okay, syntax error
you want to replace old drive with new drive… I have edited the comment above.
the placeholder remains until resilver is complete

maybe i’m missing something but im still geting the invalid vdev

sudo zpool replace NAS1 1844925148148087666 ata-WL2000GSA6454_WO L240385425

invalid vdev specification
use ‘-f’ to override the following errors:
/dev/disk/by-id/ata-WL2000GSA6454_WOL240385425 does not contain an EFI label but it may contain partiti on
information in the MBR.