Bandwidth caped at 9 Mbit with GeForce Now and tp-link Powerline Adapter

When trying to use GeForce Now (GFN) I only get about 9Mbit/s of stream and the quality is accordingly very poor, even though the normal throughput is much higher.

Network:
50 MBit/s DSL from Deutsche Telekom
Fritzbox Modem/Router
TP-Link TL-PA4010P Powerline Adapter

Setup:
Router -> PL-Adapter -> Switch -> Client

When downloading or watching other stream it is no problem saturating my DSL connection over this setup and I don’t notice any problems otherwise.
A test with iperf from a Windows client to the router shows a speed of 82 Mbit/s for TCP and about 91 Mbit/s for UPD which is the protocol used by GFN. so internally there should not be a limit low enough to cause any problems. Using GFN’s build in speed test with this setup results in the full speed of ~45 Mbit/s measured.
However, there is still this weird 9 Mbit/s cap when using GFN over the given network topology.

When connection directly to a LAN port on the router I’m getting 20-30 Mbit/s stream and really decent quality. (same measurement as above)

When connected in the way: (Router -> PL-Adapter -> Client) directly without any switch or longer runs of ethernet cable the problem still persists, but now in addition, when using GFN’s measuring tool the connection clocks in at the magical 9 Mbit/s instead of the 45 I get when the switch is present and it recommends to switch of the VPN even though there is no VPN active or even installed on that machine.

I’d be glad about any hints or pointers in directions go.

What you have to bear in mind is what GFN maybe using to class the network as very poor.

If you have a 1080p stream of data, that is going to fit into 9Mb/s easily (with compression).
It’s not saturating the link as it doesn’t need to.

What it maybe classing the network as “poor” with is actually latency which is going to be much more important in this scenario.

There is also the possibility that your ISP doesn’t have great interconnects with the datacenters Nvidia are using for this; there maybe a bottleneck somewhere outside of your network as your ISP traverses over other networks to get there.

I haven’t used GFN so this is all speculative

As stated in my Post, if the client is directly connected to the router, it works and it will actually use 30 Mbit/s for the same [email protected] stream.

This rules out a routing or peering problem on the side of the ISP. Further the latency introduced by the powerline Adapters is minuscule and therefor should not have any impact on the classification of my connection.

I have heard a lot of stories in which ultimately powerline adapters were identified as the problem. I’ve never used that tech myself but I’ve heard enough to keep it that way.

Yeah the adapter definitely is the problem and if there was any other solution than using them, I most definitively would.

Now however I’m interested in finding out the root cause if further debugging is even possible without an enormous effort.
I also already tried to setup an OpenVPN server using TCP on my vServer but then the latency actually is to bad and the results are even worse.

hi i also have this problem, i just bought those adaptors and yes it is capping the stream speed to be less than 10mbps , i tried wifi and its goes to 25mbps which is wat i want but the latency is high on wifi. i cannot understand the problem either, have u found any solution yet?

Try a test run directly into the router, if it’s fine then maybe your homes electrical wiring isn’t up to par for the adapter

Whoops looks like you did that

I wouldn’t put much faith into power line adapters in the first place
You might just have to run a Ethernet cable, if you make it yourself you can get a huge roll cheap, with enough cable and hot glue you can run it up and over doorways along the trim.

Alternatively you can try different wifi standards, they might have different latency impacts

Wait you’re using a VPN?

i have the same probleme when i test geforce now with my powerline tplink it gives me 9mbps but when i test with my router it gives me 5mbps

I found the solution. The problem is the tp link adaptor. Only tp link that supports beamforming Mimo or something its called allow game streaming, dont ask me why. I returned the 600mb version and bought the lastest one that supports Mimox2 or something. The old one was not intended for playing streamed games like that, the newest one is designed to play those games. I am currently using that with max speeds, no lags, its amazing. Hope this helps.

1 Like