Backlight function keys not adjusting backlight on intel/amd hybrid graphics laptop

Hello all,

I’ll lead in with an apology if this had already been addressed somewhere else, I’ve scoured google for the past week to no avail. Also, linux is not my forte, so if I’m missing something obvious or have failed to execute a command that might otherwise be obvious to some, I again apologize.

My laptop’s is an older model, HP Zbook 17 G2. The GPUs I am working with are as such, via lscpi:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Bonaire XT [Radeon R9 M280X]

Wiped Windows off it, loaded it to the max with 32GB of ram and a few SSD’s to make it a solid portable light virtualization platform and means of teaching myself Linux to a greater degree. Everything worked out of the box when installing Kubuntu 19.04 (chosen to help transition me from Windows to Linux easier,) with the exception of the backlight keys. The prompt for the brightness meter would pop up and scale up and down, but it wouldn’t actually change the brightness.

An ls of /sys/class/backlight/ yields two results, intel_backlight and radeon_bl0. Poking around showed the backlight keys were modifying the files in radeon_bl0, but that the intel_backlight was the one that actually changed when poking the brightness setting inside its folder.

Googling yielded that putting the following into 20-intel.conf inside /usr/share/X11/xorg.conf.d/ would fix the problem:

Section “Device”
Identifier “Intel Graphics”
Driver “intel”
Option “AccelMethod” “sna”
Option “Backlight” “intel_backlight”
Option “TearFree” “true”
BusID “PCI:0:2:0”

Sure enough, it did. Graphics were a tad wonky after that but I didn’t think much of it, until I noticed performance in 3D apps absolutely tanked. Yet more digging showed that by doing this, it completely disabled the Radon’s opengl output, couldn’t use it for anything after that.

After yet more googling, tried the acpi_backlight=vendor or video edit in grub, didn’t work. xbacklight in my attempts didn’t work. I am stumped. I can’t install the AMD proprietary drivers for the radeon gpu, they’re too old.

Any insights/assistance would be greatly appreciated, and I am more than happy to post any other necessary information I may have lapsed on providing here.

Thank you.

I ran into this exact issue yesterday. Different machine, different distro, but the same fix might do the trick.

Here’s what I did:

Find the config file named 90-mhwd.conf
Open it with nano: sudo nano /path/to/file/90-mhwd.conf
Scroll down to the section labeled ‘screen’ and add the following to the list below it just as I have it here:
Option "RegistryDwords" "EnableBrightnessControl=1" (quotes included)
It should look something like this:

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24
Option “RegistryDwords” “EnableBrightnessControl=1”

Hit Ctl+o to write out the file, then Ctl+x to exit.

Reboot the machine and see if you now have brightness adjustment.

Another option is to add the following line to the GRUB command line:
But just to note, this didn’t work for me.

Hey @MEC_777

Thank you for the reply. I attempted the fix to unfortunately no avail, it looks as if that config in particular is something specific to Manjaro (which judging from your profile picture I’m guessing you’re a fan of, heh.) Whether it is or isn’t I can’t say, but I did insert it in along side the rest of my config files to no changes.

In respect to the GRUB edit, I’d already attempted that prior to the same effect, unfortunately.

That said, the advice isn’t a total loss. I’m not married to Kubuntu, so if it can get the job done I might switch to it, though most of my experience is through the various Debian forks and CentOS/Redhat. Pacman and Arch have been conveyed to me as the ‘expert tier,’ of which I do not view myself as, yet.

Have you tried searching or asking on the Ubuntu community/forums? They might be able to point you in the right direction.

I heard that too about Manjaro before making the switch and while Arch is definitely more for the ‘expert user’, I can also say Manjaro can be easily used by the less experienced. I don’t consider myself a Linux expert at all. Enthusiast and experienced, yes.

After trying Arch, it’s definitely on a ‘higher-level’ and you need to know what you’re doing both during and after installation. Manjaro, on the other hand, is no different than running Ubuntu or any other major distro aimed at user-friendliness. It is based on Arch, but stable and has the benefit of being able to use AUR along with several other features, like the ability to easily swap Kernels. It also has really good hardware auto-detection and compatibility.

Ubuntu is a solid distro though and if it’s what you’re used to and what you like, I’m sure there’s a fix for this issue. If you’re curious about Manjaro (or any other distros), you can always install and try it out in virtualbox first and see if you like it. :slight_smile:

Bit of a delay in replying, but I don’t like leaving a thread with no closure.

My post on Kubuntu forums has no reply after a month at this point. My post on Ubuntu forums didn’t even have a view until 7 days in. I always thought Ubuntu was a somewhat popular Distro, especially after Wendell’s highlights on it both on Level1Linux and with LTT.

I looked into Manjaro and saw that they had a KDE distro in official support, made the incentive to switch fairly easy since KDE serves my creature comforts for the moment. Grabbed it, slapped it on the laptop, worked beautifully with the only tweak on my part needing to re-insert the tearfree option into the config.

Pacman is a bit of a beast to learn compared to apt or yum, but has been reasonable to deal with for me so far.

So, while not the most convenient solution it is nevertheless a solution, thank you very much @MEC_777.

It’s not within the scope of my original question and doesn’t need to be answered, but would you happen to know of a better terminal than the one built in to KDE? I’ve come to use Tilix but I know that’s best used on Gnome.

I’ll close the thread as solved by tomorrow if I don’t hear back from you, but thank you again.

1 Like

I’ve always just used the default terminals that come with whatever distro I install. Yaquake terminal is a drop-down terminal in Manjaro KDE. It should already be installed and start up automatically on boot. Hit the F12 key to have it drop down.