Return to Level1Techs.com

Automatic scaling issues on windows 10

Hi, so i’ve had issues with a display i’ve been rocking for a while. I’m running an R9 290, with a 4K monitor attached to the HDMI slot. I’m aware this limits me to 24Hz, but the idea was that i’d be upgrading to a nvidia 30 series card before lockdown was announced. For obvious reasons, being that i don’t shit money, this hasn’t occurred and i just want my setup working as best it can with the hardware i’m using.

A windows 10 update came out during 2020 and was installed on my machine, and this has never been the same since.

When playing games, my R9 290 is woefully inadequate for 4K. I just bump the res down to 1080p and play like that. The issue is, that when i do this now, the render resolution is reduced, but not the video out resolution. So my monitor thinks it’s showing [email protected] when in Settings → Display under windows it’s [email protected]

If i go to advanced settings, i can change the refresh rate there, and if i push it up to 60, it will reduce the resolution to 2560x1440 that it’s pushing to the display, however the render resolution is [email protected]
If i push that to 120Hz (a mode my monitor technically doesn’t support), the output resolution drops to 1920x1080 120Hz

I have found nothing in the past 2 years after countless hours of searching that will let me turn this off. I want the res in windows to be the res that’s being pushed to my screen. In games, i need frames. Not a powerpoint presentation. while i accept that i’m having to work around by going into advanced settings, i just want this thing to stop scaling the resolution up when there is literally zero point in doing that and it just leads to black bars along the top and sides as the aspect ratio doesn’t quite fit.

Here’s the obligatory specs sheet:

Operating System:   Windows 10 Pro for Workstations Version 20H2 (x64)
CPU:                2x Intel Xeon E5-2650 v2
RAM:                128GB DDR3 @1066 MHz (16x 8GB sticks)
Motherboard:        Intel S2600CP (latest UEFI & BMC rev)
GPU:                AMD/XFX RADEON R9 290 4GB (reference design) which runs the 4K monitor.
GPU2:               Nvidia NVS 510 which runs all the 1080p monitors.
Boot Drive:         LITEONIT LCS-256L9S-11 256GB
Games library disk: LSI 1068E, RAID 0 of 4x 1TB Western Digital RE4 disks
Displays:
  Center:       iiyama ProLite PL5540UH [email protected] HDMI
  Top left:     iiyama ProLite B2475HDS [email protected] DVI
  Top right:    iiyama ProLite B2475HDS [email protected] DVI
  Bottom left:  iiyama ProLite B2475HDS [email protected] DVI
  Bottom right: iiyama ProLite B2475HDS [email protected] DVI

Any ideas?
I’ve checked some of the obvious settings like Radeon Software → Settings → Display → GPU Scaling (Disabled)
It does make a difference, but it doesn’t solve the problem.

A full reinstall of windows has been attempted. The problem still occurs. This also occurred with a Radeon RX 5700 XT with the Nvidia card removed. Though my machine has issues with BSODs using that particular graphics card.

Try Linux and join the Dark Side today. At least tech savvy people can try to help vs no help at all from your Microsoft overlords.

Unless you have requirements to run MS Office, Adobe and online competitive multiplayer with anticheat enabled, in which you have my sympathy. Have a free topic bump.

i’ve honestly tried this numerous times, though i extensively use Autodesk CAD products, MS Office etc.

But basically i can’t linux on the current hardware setup due to software requirements and X11/Wayland being buggy as crap when using multiple GPUs.

i hear the inevitable next logical question: Why am i using 2?
I’m aware the R9 290 is technically capable of pushing 6 monitors, however in practice it’s more like 4 that flicker every now and then +1 that’s ok. I know why that is. It’s because the bandwidth between some of the connectors on the card are shared.

I even made a fancy conky theme back in the day i’d like to use again. Probably not going back to linux until i can sort that issue out. Be it by purchasing a GPU that actually works as advertised, or figuring out how to create X11/wayland configs that work on multiple GPUs. I hear it’s possible, just most OSes don’t work out of the box.

1 Like

@GreatGrogrodor The behavior you describe puzzled me a great deal. Web search turned up this brief link about the tech that is doing this (so you may not be crazy…). It has a couple of hints that might help you get the desired “physical resolution”. Sounds like a driver that is NOT WDDM 2.0 compatible might help, if you can find one. Or perhaps the terminology used will help with more web search.
Windows 10 Virtual Monitor Resolution

This link seems less promising, more about super-sampling, but in the general ballpark & maybe related:

Sorry you are having this problem, but it is interesting - thanks for sharing.

1 Like

That’s exactly what i was looking for. It’s the Active Signal Resolution that doesn’t change in Advanced Display settings until i increase my refresh rate.

I’ll have a poke around in the registry and see what i can find.

Many thanks!