Audio Line Out Not working in Ubuntu, Linux Mint Cinnamon or Manjaro KDE

Hi all,

I’m having a problem getting my line out on my MOBO working in Linux.

I’ve tried on Ubuntu, Linux Mint Cinnamon, and Manjaro KDE, but the situation is Weird. I can get the sound to come out of the Headphone jack on the front of my case and I can get the sound test to work on my monitor’s speakers through the GPU. But as soon as I plug my speakers into the Line out now the sound comes out of the speakers.

All of the OS’ can detect when the line out jack is plugged in and occupied but cannot drive sound to the speakers. When I test audio on this jack nothing comes out of the speakers

I have installed the ALSA on Manjaro and the ALSA mixer but that hasn’t gotten me anywhere

Quick Hardware Summary

Threadripper 2950x
X399 Gigabyte Aorus Xtreme
EVGA GTX 1070 SC Black Edition

I’ve been running into this issue with the OS running from a live USB and from an install on my SSD.

I want to run this machine as a dual boot system and I have windows installed on an NVMe SSD For multi-media work and my Linux Distro of choice on a SATA SSD for Web Development enviornments.

I am partial to the Manjaro KDE Interface but am Willing to switch if I can get my audio to work correctly


I’m not fully sure i need to check out wenn i have time.
But it could be that your particular board has two separate audio circuits (chips).
So it could be that you need to install a specific driver for it.
Or that you need to switch outputs in the audio mixer.

Maybe @wendell knows out of his head which specific driver is needed,
or how you have to set the outputs up.
Since he has played around with the Gigabyte X399 Designare EX.

1 Like

so line out and speaker out are different ports… try different ports. I ran into something like this on mine and it was just outputting on not the physical output I thought it was. one is amplified output, the other is not.


Hello Everyone,

Thank you all so much for the help. I got it working on Manjaro and I honestly wish I could tell you the logic behind this issue.

The audio on my Line out now works but I have to select *Headphones (uplugged) * for my audio out for the line out jack to send signal.

I installed Some of the ALSA recommended programs from the Manjaro Linux ALSA Wiki pagei and that may have helped me along.

I wish I could tell you more but It’s working even if it seems a little crazy.

Something I will note about this motherboard. I had an issue with the x399 Aorus Xtreme unable to send audio to the line out when Ryzen Master was installed on the latest BIOS (f5g) in Windows 10.

Here is a list of the ALSA software that I installed to help getting this running.


1 Like

As a side note, If anyone is looking into purchasing this motherboard. I have to say with a heavy heart that I wouldn’t recommend it. Several other people have had issues with getting it to run ram above 3100 MHz and it has a slew of other janky issues. I really like how the board looks but unless you need three networking ports on the Motherboard I can’t recommend the purchase.