Audio issues Asus M5A97 EVO R2.0

Hey everyone.

Ive got a wierd audio, issue with my motherboard. i had issues from the start, but i did not realy expect that it could be something with my audio (driver) or motherboard.

THe problem is wenn i play flash / java games, with sound, my systems seems to get unstable. I get some stuttering. The wierd thing is doe, wenn i disable sound in those games, it seems that that is solving the problem.

But thats not realy all. somethimes, wenn i wacht streams, or listing to music in winamp. somethimes the sound dissapears. or let the system acting kinda wierd for no reason.

I allways thought that it was some kind of a flash problem. ive got my bios updated to the newest version, this did not solve the issue. the audio chip on the board is the ALC-892 by the way from realtek.

I personaly think that this is a audio driver issue. somethimes wenn i watch a stream and afterthat i wanne listen to winamp music, somethimes i get no sound or system is  acting wierd. then after a reboot, everything is fine again. It looks like that the audio driver causes something like a lag. Especialy if i play online java/flash games, it realy lag's alot.

I just had a strange issue, im a fanatic online pool player, i was starting to play pool, but with the breake shot, the game froze. wenn i disabled the sound. i was able to play it. After a reboot, i could play the game with sound enable, but somethimes it stutters abit. So it seems to be abvious that it´s something with the sound part on the board.

So it seems that there is something wrong with the sound driver, i have to say that i allready tried all the newest drivers i could find on the asus site.with no luck.

Could the realtek driver maybe in some way, conflits with the Radeon 7870GHZ HD audio driver?

Or could there be something horribly wrond with my mobo?

i hope some one can shine a new light on this. cause i´m totaly out of idea´s.

Im sure you've explored all the usual suspects that could be doing this but...

Maybe check how bad the DPC latency is: If you get spikes or the average hovers around the 500ms+ mark or and/or spikes hard then that will be your audio problem. In that case - Disable High Precision Event Timer (HPET) if you're using windows. Plus update your motherboard BIOS. Plus a few other things - but its covered in the replendance page.. I think.

Hope this is of some help. Peace.

I would uninstall both audio drivers then try each one individually to see if it helps. Or disable one or something if you can.

I have an MSI Z77A-GD55 motherboard with an ALC892 that has bullcrap audio issues as well. Certain games I have to make sure that the headphones are plugged in before the game starts otherwise there will be no sound. Other times the sound just cuts for a second or two then returns. Heck, I can't even get the back panel audio port to work correctly because whenever I plug anything into it the sound literally fades out almost as soon as I plug anything in. I'll start at 10% volume and it will work for a few seconds, then it starts fading and after 10 seconds I can't hear anything even at 100% volume.

TL;DR: I have the same audio chip on a completely different platform and get audio issues as well.

EDIT: To be fair, the audio does actually sound pretty good when it works. Probably nothing compared to a DAC/amp combo, but actually rather nice for basic onboard audio.

Thank you so far, i did the latency test, and i do indeed get an occured problem. Seems that the there is an throttleling issue somewhere. network related, or the driver related.. this would probably be driver related. but i allready tried all lan drivers from asus. The other test i saw some spikes, but it was arround 500us, i had one spike at 1000us.

Here is a link to picture.

@wiemerimer, its indeed a very strange issue. i see that you also have sound issue, with the same audio chip aswell, this is abit wierd. i also have sort of the same problems with mine, somethimes my sound goes away, after used winamp, and then wenn i click on the audio volume control, i do see faders, but no sound of the speakers. this seems like a windows issue. or a conflict with the Realtek and the Radeon HD audio driver.. i think cause wenn i do a reboot, then i have sound again.


Disable each rear io controller (usb,ethernet,everything except audio) in device manager (run kb,mouse off front panel ports). Re-run dpc monitor, play audio clips etc. See what reading are. Then enable each rear port one at a time. Chances are it is the ethernet ports (easy fix with an intel NIC). If readings are low and not showing spikes its the onboard audio, in that case its easier to just grab a cheap card like a Asus DX card (or similar) that comes with low latency drivers.

Also re-installing the radeon driver package without the hd audio drivers.

99% of am3/3+ boards suffer from bad dpc latency especially in a windows environment. The best boards thus far have been the high tiered z77 boards (like my current board - p8z77v deluxe - 30 to 50ms at most).

If it cant be resolved then RMA the board. This was the case with the old rev1.0 x58 UD3R's and some of the rev1.0 p45 775 boards, both had design faults and the latency was really nasty. The highest I got my p45 ud3p was 21k spikes making audio and video playback impossible in windows (of which suffered a cold DICE death oc run).

Thanks for all the help sofar.

i will definitly gonne try some furter things. if i cannot found the clear issue. then i probably not gonne rma the board. ive got it a year now, still warrenty, but the board costed me €95 that time, so if i need to rma it, im stuck for a few weeks without computer. So then i will probably gonne look for a new mobo, cause i wanne have a red/back board anyway. i was thinking to grab the Asus crosshair V Formula Z, but the supreme FX3 soundchip is a realtek chip as well, but i don´t know which one. or if its a bug with this particular sound chip and driver, or if its just the problem with my mobo it self.

I think i found the problem.

i did the latency test wen playing a song in winamp. with my network / internet connection enabled. after 2 minutes of testing i got the same error again. i did not had any browser open or something.  I did the same test again but now i disabled my network adapter, and tested for 12 minutes, and i did not get any error.

So it seems that there is an issue probably with the lan driver. or lan chip. or at least there is some sort of latency issue between the lan and the sound chip.

Yep thought as much. Glad you nailed it down. Grab a cheap Intel NIC and disable the onboard controller.

Yeah probably the realtek lan chip on my board has some issues, i will look if i can find some better drivers some where, atleast i will not find them @ Asus offcourse. lol

Otherwise indeed a diffrent lan card, further the system works fine, but it just annoyed me abit. ☺

I can´t find any better driver unfortunatly, maybe i gonne upgrade my board to the Crosshair V Formula Z, cause this board has an intel NIC.

Anyway first thing i gonne try is to install windows 8.1 pro. on a second HDD just to look if that gives me some improvements.