Return to Level1Techs.com

Attention amd vfio users do not update your bios

Yep problem has still some issues with some AMD gpus spoke to Aiber about it, he doesnt have any to play with so not sure what it would be. However patch does work. Restarting windows while in VM for amd gpus is kinda wierd and can crash the vm at least for my build.

@pantato that happen to you too ?

Might have to wait for bios fix from asrock to be fully functional but this will do!

gotta love it when you bought into a platform because you distrusted the industry leader and then the little guys break the biggest feature you wanted on it 3 times over the product lifecycle with months or years inbetween fixes

1 Like

nope, VM is fully functional for me. We have the exact same hardware. Maybe try the other method of kernel compile?

edit: maybe try updating windows drivers?

This looks like a version of Geoff’s patch lol it’s just a misinterpretation of the pcie spec with who/what is responsible for save/restore config… Intel does it at a lower level outside the os iirc

yep, he tried it on a hunch and it worked.

which means they re-broke the same thing somehow.

I’m on it ™

2 Likes

good to know man keep us posted.

Sorry to bump this but with Ryzen 3000 coming out I was wondering if there had been any official communication from AMD on this, or is AMD now a dead platform for vfio users?

I am happy to report that x570 is generally better than it’s ever been on the AMD platform. It does vary from board to board. Check out the Linux channel video.

For older boards you should wait. The engineering time is focused on newest boards first seems like because newer boards have some other quirks

In a week or two check back here but I’d say things will be fine.

3 Likes

Thanks for the quick update.

Just to confirm the latest Gigabyte BIOS for the AX-370 Gaming 5 based on AGESA 1.0.0.3 AB doesn’t work.

Doesn’t work as in you get the same pci header type error or some other way? I thought the kernel patch still works.

still getting the pci header error.

I can’t patch the kernel as I’m on unRAID.

What version of unraid are you on? I wouldn’t generally recommend unraid as a VFIO platform.

Have a look at these posts on the unraid forum, report back whether you still have issues:

I have upgraded to an x570 from a B450. (Still running a 2600).
Have lost the abillity to passthrough the GPU on unraid also with the pci header error.

use VFIO

Hi, I am trying to pasthrough an RX590 with a 2700x, x470 Taichi Debian host to a Win 10 guest:
I follow a guide (I cann’t put links to it)
But I get the same Error: unknown pci header type ‘127’
I tried to patch kernel following another guide to it:
But then, when I try to “make” it, I get this error:

dpkg-source: información: el paquete tiene marcas borrosas lo cual no está permitido, o está corrompido
dpkg-source: información: si quilt aplica el parche «debian/dfsg/arch-powerpc-platforms-8xx-ucode-disable.patch» adecuadamente, utilice «quilt refresh» para actualizarlo
dpkg-source: fallo: LC_ALL=C patch -t -F 0 -N -p1 -u -V never -E -b -B .pc/debian/dfsg/arch-powerpc-platforms-8xx-ucode-disable.patch/ --reject-file=- < linux-4.19.37.orig.q2Fx9H/debian/patches/debian/dfsg/arch-powerpc-platforms-8xx-ucode-disable.patch subprocess returned exit status 1
dpkg-buildpackage: fallo: dpkg-source -i.git -b . subprocess returned exit status 2
make[1]: *** [scripts/package/Makefile:75: deb-pkg] Error 2
make: *** [Makefile:1379: deb-pkg] Error 2

(I have spanish Debian, sorry for that)
What should I do to compile patched kernel? Thank you in advance.

I’ll recommend using Arch, as always, though. It’s much easier to do these types of things. Also, make sure you’re using this patch: https://clbin.com/VCiYJ

that is NOT the patch for this issue

I tried with this guide (I said another but it was just I wanted to say it was guided to :smile: ) and patch.
Switching to Fedora or Arch is something I have in mind if I cann’t get successful.