Attempting to use raspberry pi to connect 2 networks

This is probably in the wrong catagory, but I’m attempting to use a raspberry pi to connect 2 different locations together via vpn. The main location is currently running unraid with wireguard installed and openvpn running in a docker. The secondary location will have the raspberry pi connect the lan over there to the main location’s lan. I for the life of me may have bitten off more than I can chew attempting this as i have no experience with pi’s + little cli setups. I have however have tried using a guide that was originally to be a “Downloading Megalith” on make use of, and used the vpn setup part of the tutorial and the client file downloaded from the openvpn profile. Should i scrap this entire idea? or was I close to finishing it?

this sounds like a textbook wireguard use case.

  • Do your 2 networks/lans have non-overlapping subnet addresses?
  • Do you have a route for the other lan going through the pi/unraid box?
  • Does your pi/unraid have any firewalls that need looking at?

What have you tried so far? have you tried ping / tcpdump or traceroute?

Yes I’ve seperated the subnets to and .
the unraid box is on the subnet of at the primary location. The unraid box I’ve setup wireguard (to allow me to remote in via my phone to handle any issues remotely) and currently 2 of the locations use a openvpn docker in unraid to communicate with each other via a computer at the secondary location. But what I’m trying to do is a lan to lan setup so all computers communicate to each other with the potential of bringing in a 3rd location once I can get locations 1 and 2 talking. Currently I managed to get the pi to connect to the 1st location via openvpn (still trying to do it with wireguard) and ping the computers that way but I haven’t figured out how to route just the necessary local traffic from the lan the pi is on to the lan of the unraid server. My apologies for my ignorance as this is my 1st time doing something of this nature. There are no firewalls that are blocking connections and I’ve port forwarded the necessary ports on both routers.