Return to Level1Techs.com

Atheros QCA6174 piss-poor performance on Ubuntu 20.04

Hey all,

I’ve got a Latitude 5570 that has a Atheros QCA6174 wireless NIC. I get absolute garbage performance from my Wifi, which is a Unifi EAP-Pro that’s 60 feet away at max when i’m inside. When i’m 10 feet from the AP i’ll get 1-6 mbps down/up, and at 60 feet i won’t even be able to browse the Internet. Any Windows based PC, or other Linux laptop i have get’s great performance from the WiFi, so it’s not the AP.

Has anyone run into problems with that WNIC or similar?

Hey!
Your best bet is replacing the Wi-FI NIC with an Intel 8560, 9560, AX200, AX210, since those are cheap and much better supported under any Linux environment and looking at the replies on reddit.

But, if you need to stick with Ubuntu 20.04 LTS rather than updating to 20.10, you could try updating the kernel to the latest version available and see if anything changes.



There could also be a hardware fault with your machine, perhaps one of the antenna cables was unplugged, or something like that you should definitely check out.

I have run into some different problems with a different Qualcomm Atheros wireless chip. I get the feeling that Qualcomm Atheros doesn’t do too great of a job with its firmware.

My Qualcomm Atheros QCA9377 in my Dell Inspiron (i5) kind of stalls the connection after a random, though usually long, period of time. The WiFi network is formally connected to, but no packets pass through, requiring me to disconnect from and reconnect to my network; that’s with the latest firmware. With a the API level 5 firmware (just move the level 6 firmware outside of its directory and it will load the older one on the next reboot or next removal and reinsertion of the ath10k_pci module), manually pinging some IP address, like say ping 1.1.1.1, actually manages to brute-force the connection back into functioning, but it’s not a much better experience than just disconnecting and reconnecting, so…

No, manipulating the power management settings does not do a thing. No, changing the kernel does not do a thing. Yes, the Dell PDF states that the Inspiron should have Intel WiFi, but this is a unit which was bought from a Bosnian retailer, so…

Realtek isn’t all rainbows and sunshine either, but:

  1. The chip in my mother’s laptop that’s from 2014 worked without a flaw on Linux, at least on a LiveUSB, since the first time that I’ve tried using it with a LiveUSB, which is admittedly three years later, but this QCA chip didn’t exactly come out in March, so there was definitely enough time to get the support ironed out in the firmware.

  2. The chip in my previous laptop didn’t really work at first, but I found a workaround online pretty quickly. It meant sacrificing Bluetooth performance for WiFi performance, but such is life. The chip was properly supported by kernel version 4.16 at least (I discovered UKUU at around when 4.17 came out and saw reports on Manjaro forums that 4.16 was the magic version, so take that as you will). Compared to how long it took for me to discover that I needed to set iommu=soft to get the HP Pavilion booting, not to mention never having proper resume support due to the IOMMU, the workaround was a decent experience.

I haven’t had experience with your particular chip, so I can’t say anything conclusive about it, but if it’s anything like mine, well, I’ve already said what there was to say about that. Here’s hoping that a kernel update is the final piece of the puzzle you need to complete your laptop.

Have a nice day!


Edit: I didn’t realize that this tread was almost a month old. Sorry!

1 Like