Asus Zenith II Extreme Alpha + 3970x + 3600MHz CL16 + Raidexpert + Linux

So i ended up spending a fortune on a build with a hope that it will last me long.

The RAM kit bought from G.Skill has Zenith II Extreme Alpha in its QVL list, i was able to load the XMP profile, installed windows and all is good.

The issue is i have populated all 5 NVMe slots in a hope of creating RAID volume for boot drive + other snigle drives for alternative OS (such as linux).


1- I sometimes had the case of Bios freezing, or the whole Raidexpert option disappearing from the bios menu, is that because of the 3600 RAM profile?

2- With running on stock clocks, i can’t seem to be able to get RAIDexpert running neither in windows nor linux. In Windows, even after installing the Raid driver / Raid expert software, nothing would come on scanning. the drives would appear as single drives rather than RAID 0 created. same on linux. (note, in all those cases, i would be running an OS off an NVME ssd at the back of the motherboard)

3- Do i need to create a single volume array in Raidexpert for single drive in able to use them with nvme RAID enabled? or would it run just fine of legacy mode?

4- Which distro would run good for TRX40 + 3970X ? which kernal would i need to have all devices recognised on MB?

5- with lack of official block diagram of motherboard, the Asus manual gives the impression that all 5 NVMe slots runs directly to CPU PCIe rather than through the chipset, anyone can please confirm? Can i sue Asus for this lol?

Finally, i advise anyone who is buying this motherboard or for that matter planning to build a Ryzen TR workstation to be patient, and seriosly consider intel because of the software supprt. I still run my trust EVGA X58 Classified Motherboard with First Gen i7 980X just fine with RAID on SATA (both SSD and HDD) rock solid for 10+ years. very dissappointed to say the least on AMD…

If someone can call on the linux guru on this forum that’ll be great.

Linux and hardware RAID don’t mix well. But if the S/W doesn’t work in Win-OS either, consider it faulty and stop using it. As for using all NVMe slots, read the manual if there’s any limitations regarding other parts of the system that may be affected.

As for your rant on AMD, any issues you have are not related to the CPU, and/or chipset so is therefore unfounded.

I’d say Fedora and Arch are pretty good

I think it’s true.

If you scroll down to storage, it only lists SATA under the TRX40 chipset, which leads me to believe that all the M.2 are wired to the CPU directly.

Could be, 3600 is not officially supported on TR3000. It probably requires a great cpu sample, great RAM sample and probably a good mobo too, to get that speed with any stability.

Why don’t you go down to 3000 or 3200Mhz w.r.t RAM and see if the RAID stuff works properly? Also try Windows lol.

The RAM kit has been tested against this specific motherboard and this is why i ordered it:

So RAM should be fine. What Asus don’t tell you is that the moment you overclock, BIOS says some Gen 4 devices might not work in a stable manner. You don’t see this on specs along with overclocked numbers.

I think the Asus manual is wrong, and the unofficial diagram on anandtech is true, the DIMM M.2 and back slot are all run through the chipset. Testing individual NVMe’s speed confirms that. 2 of those NVMes performed slightly better on sequential read (i.e. 500 GB 980 Pro tested 6800 MB/s on2 nvmes, other two tested 6500 MB/s).

I somehow managed to get Raidexpert to work on windows, i installed Win 10 Pro on RAID 0 for 2 nvme which believed to be the ones directly hooked up to the CPU, got 12 GB/s Seq Read, still not happy with over all performance, my gaming laptop MSI GT72S 6QE has two 128 NVME PCIe 3 in RAID 0 feels more responsive, boots faster than this.

I’ll give Fedora a shot, Arch linux doesn’t have GUI installer does it?

Seriously? It’s 2020 and i need to load 3 different drivers for windows to detect a raid array?
Cause my 10+ year old intel system didn’t, it and wasn’t a “workstation” grade HW.
Having said that, you can easily miss up and overwrite a raid array member this way, besides the 5 NVMe’s populated, i have another 4 in a Highpoint SSD7505 card. At the least the later is a proper RAID card where ther RAID array will popup the way it is configured.

I was an early adopted with the initial 1950X release, and have surely learnt my lesson. Sticking to Intel moving forwards as all the headaches I’ve faced with AMD are not worth it. Up to date I’ve not been able to get my TR4 boxes to boot Win10, but thankfully they are stable with linux so I’m able to get some use out of them.

@wendell have you tried RAIDExpert with overclocked system? Windows or Linux? Which Distro?

I have bought this MB after watching your Youtube video about it. I really appreciate it if you could throw any hints performance wise.

As said earlier, i have all 5 NVMe slots populated along with another 4 in Highpoint SSD7505 controller.

Sorry for the trouble and random mention.

Mild overclock should be safe but extreme overclock may regress.

I don’t use RaidXpert with linux. Use one of the md guides I wrote for linux – it works much better.

Mixed os with RaidXpert is not supported really and you get mixed results as you’ve discovered. You can’t really create one big raid volume then dual boot it. You can but it’s way way not newb friendly. Not recommended.

1 Like

Thanks for replying.

Alright, i should probably then keep my Highpoint SSD7505 as it has hosts the raid controller chip on the device (supports PCI-e 4.0) i’ll try and see if linux see it. This is poor’s man Liqid honeybadger.

Raidexpert suggests RAID 5 is supported on Threaripper, i was thinking of using that on SATA with RAID 5, i’ll see how that pans out.

So it looks like single NVMe as boot drives, but can i pass through a whole NVMe to a VM in windows orl inux?



maybe in specific instances but, servers use linux and hardware raid all the time.

Yeah and MS and linux have had 10 plus years to roll those drives in to the later OSes and kernels. new stuff usually requires a drive or 2.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.