Asus Z97-A 4x8tb Ironwolf HDDs not being recognized [solved]

After about a year of talking about that Im gonna probably do that sometime soon tm. I´ve now decided to upgrade to RYZEN and use what I used up until now to build a NAS / homelab Server.

The NAS PC now looks like
MB: Asus Z97-A
CPU: 4790k
Harddrives: 4x Seagate Ironwolf 8TB and 1x Samsung 860 evo
PSU: Seasonic FOCUS Plus 550 Gold (That´s also new, I already had a Seasonic PSU before with 650w, witch I plan to keep using for my Main PC)

Now my problem is that I cannot get all of the HDDs to recognize. I got 3 of the 4 Seagate Drives to recognize. But once I plug in the 4ths, there is only 3 HDDs still (does not matter witch one I plug in) and sometimes it goes down to two.

I´m thinking the Mainboard might not be able to handle it for one reason or another. I expected it to just work, but it didn´t. It has 4 Sata III ports and 2 additional SATA ports that are 10gbit shared between the two ports and the m.2 depending on what you plug in. It´s probably not possible to plug in botht he m.2 and both sata ports, but that´s not what I´m trying to do anyways.

The SATA cables surely aren´t an issue, especially because I accendently bought 4x3 SATA cables instead of the 4 I really wanted to buy. And now with all new SATA cables that I just happened to have by accident, it still does not behave any different.

The PSU itself I would hope is not an issue, but maybe that I plugged them in with one single modular cable with 4 SATA power connectors is a problem. Have to try that. Although, from what I read about 20 HDDs is about the limit for HDDs with one cable. 4 is a lot lower than 20.

Tomorrow evening I´ll get my Mainboard and CPU (it´s already there, just gotta pick it up) and then I´ll rebuild my PC and get that to work before I do anything on the NAS. Then test all the HDDs indivially in my Desktop and see if they all work properly.

In case the mainboard is the issue. Do you know of any good PCIe SATA expansion cards that work on Linux preferably without installing anything? Specifically I´m planning to use CentOS as a host OS this time around if that matters at all.

Looks like it was actually a uefi issue rather than anything else. In the UEFI it does not show all the drives.

I tested all the drives on my new machine individually. All of them worked. Then installed CentOS on the old now NAS system and plugged back in the drives one by one and they all showed up first try (in the OS). But aren´t all in the UEFI.

Thinking of witch I should (probably) revert the BIOS back to the stable pre meltdown/spectre versions. Dunno, maybe not. But the term “Beta Bios” seems like the bigger red flag than meltdown/spectre on a Linux Server/NAS. Also more faster.