Asus Z87pro

When booting it up I am getting a A2 on the Led on the card i dont know whats wrong i've tried everything and it just keeps giving me it my specs are


Btw I dont even get a screen on my monitor someone please help I am really stressed out

A2 is a IDE connection error try booting the mobo with no sata devices (hdd/dvd drive)

If you can then get it to boot to bios set all the sata devices to AHCI in the bios and reboot with the hdd reatached.

If that dosent work reset the bios by removeing the bios battery for 1-2mins (asus often test mobos before thay go out and may not have the bios set to its defults)

I did that already and then it goes to 99 and then i still get no screen.

take out your gpu, and connect your monitor to the onboard video port on the motherboard, and look if you get a post screen then.

Grtz Angel ☺

Still getting that A2 when I did what you said. No bios coming up on screen

okay let your monitor connected to the onboard video port. try  with only one ram stick, try every ram slot. piece for piece with both ram sticks sepparate.

I tried it :( and same code everything is running and fine im just not getting anything on my monitor no bios or anything & Still getting that A2 on my mobo

i think you ran into bad luck then, probably a doa motherboard, just rma it.