Asus z270-p no boot, no beep


I’ve built a computer with a Asus Prime Z270-P motherboard, a I7-7700K and HyperX Fury RGB DDR4 3200MHz 32GB 4x8GB 3200MHz DDR4 CL18, XMP Ram.

I get no boot, and no beeps on the speaker that I have connected to the motherboard.

I’ve tried reseating the cpu a couple of times, but can’t see anything wrong.

Is there something I’m missing…?

Sorry if the post is in the wrong place :slight_smile:

It seems to be a dead cpu.

Am I to assume these are used components? The AMI uefi should beep 5 times consecutively if there were a cpu error. Which port do you use for the display onto a monitor? (DVI or HDMI from the motherboard if you using the IGP). Have you cleared the CMOS? Reset through jumper pin?

The CPU was a used component yes.

The motherboard manual says, if there is an error with cpu or ram that make it unable to post, it will not beep.

I tried an I5 cpu from a working machine and it booted up. Tried the I7 cpu on a known good motherboard, and it did not boot there either.

The seller wanted it in return to test it out himself.


hmm, I’m glad its been resolved and worked out for you. I’ve had this motherboard; very sleek and booted everytime. There is no viable upgrade path. sans editing the eufi and shorting some pins on coffeelake cpu’s.

1 Like

Thanks :smiley:

I got an i7 6700K cpu in the mail today and it booted right up :slight_smile:
So the machine is ready to go.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.