Return to Level1Techs.com

ASUS WRX80e-Sage Won't Post, Q code error loop

Here is a short video of the Q Code error loop:
**For some reason, as I went to post, it would not let me add a video or a link, but I am happy to share in the comments if I can.

Please help, I am at my wits end with this motherboard lol

Thank you!

PS- Before the q code error loop I was getting a 94 error code “PCIe Enumeration”. It seems to work ok with 2x 3090s, but when I tried to add the other 4, for a total of 6x3090’s I was getting an error 94 error code.

Thanks!

Sounds like an interesting build! How many PSU’s, which models, and how are they connected? Are the GPU’s all water-cooled, or are they on PCIE risers? If risers, gen3 or gen4?

Thanks! I’m excited to get this working 100%

I’m trying to link the video but I keep getting blocked.

> How many PSU’s, which models, and how are they connected?
2x Corsair HX1200’s, one connected to the ATX power connection on the board, and the second is linked with a dual PSU adapter.

> Are the GPUs all water-cooled, or are they on PCI-E risers? If risers, gen3 or gen4?
GPUs are not water-cooled; they are on PCI-E risers.

The risers I have are Gen3.

Side note: I’m using 1x Gen 3 risers on my daily driver workstation with 3x 3090’s, 2x 3090’s are connected to the board, and the third via a riser, and it seems to work ok. The board is an Arous Extreme 570.

I assumed Gen 3 would be ok for this bigger build since I’ve been using gen 3 cables on my daily driver machine for a few months.

Thanks for your help!

Ahh, Gen3. I’m using Gen3 GPUs (4 x Kepler Titans), and had to switch [PCIEX16_1:7 Mode] in the BIOS for each slot.

In the BIOS, go to [Advanced \ Onboard Device Configuration].

Scroll waaaay down until you get to [PCIEX16_1 Mode].

For each slot (PCIEX16_1 : PCIEX16_7), change to [Gen 3].

While in the BIOS, [Advanced \ PCI Subsystem Settings], also make sure that [Above 4G decoding] is ON.

PS: one more thing: I used the onboard VGA while setting everything up. Then when I was trying to sort out my Gen3 GPUS, I also set the motherboard switch for onboard VGA to disabled. But I’d guess this is not necessary.

Good luck, and please report some benchmarks!!

Thank you again for your feedback

I changed all seven ports in the BIOS to GEN 3. The Good news is I am no longer getting the PCIe enumeration error code, but now I am getting a D4 error code which I think is a PCIe resource allocation error.

I can’t wait to post benchmarks! lol, It will happen one of these days.

1 Like

If you manage to get into the bios try to disable fast boot and CSM.
I have read another topic on this forum with similar symptoms.
Maybe some information in it might be useful to you.

1 Like

Thank you! I did try to disable these settings, but I am still getting a D4 error. Could an underpowered PSU cause the issue? The ASUS WRX80 manual suggests I need a 1500w PSU with more than two cards. I have 2x 1200w PSUs connected via a Dual PSU adapter, but I wonder if I need to bump them up to 1500w because maybe these boards do some checks at the beginning to see if the PSU meets these requirements. This one is a tough nut to crack.

Have you made sure you’re on latest bios? There.some options about how much bar space you need. If it works with most but not all of the gpus you may need to enable above 4g decoding or mess with rom bar allocation

I had two v100s 32gb plus a 2080ti and it took a new bios and bar settings to get all three to work at once

Hey Wendell! I am on the most up-to-date BIOS; unfortunately, that did not do the trick. Glad I’m not dealing with the Q code loop anymore or the PCIe enumeration error code, but now the D4 code is being stubborn.

I very much appreciate everyone’s suggestions. On the long shot chance, the MB is looking for a PSU with more juice, I’m getting a 1600w and a 1200w. I know it’s a long shot but I feel like I’ve tried everything else.

You do have all the extra mobo power headers connected too right?

I sure do, every single one.

try just doing the ones at the front edge of the motherboard, and you know that the 8-pin for cpus is different than the 8-pin for pcie, and the front edge of the mobo has both kinds?

Yep, got 2x 8pin CPU ports plugged in and 1x8pin PCIe at the top corner. I do know the difference and have triple-checked before giving the board power that I used the correct cables.

The bottom of the board has 2x 6pin PCIe power inputs.

Are you saying to remove the 2x 6pin at the bottom?

Yeah. Does it post if you remove just one gpu?

Did you use the jumper to disable the onboard vga?

Wendell, I got it!

It was my ignorance of CSM enabled vs disabled. When I started this build, I read on quite a few forums that I needed CSM enabled, which did allow me to boot into Windows but prevented the board from utilizing more than 2 cards. I was diving through some more threads on here and read that someone disabled CSM and got it to work. So the next step was figuring out how to get Windows to boot while CSM was disabled.

To make that happen I had to hop into the Windows repair console, open up a command prompt and do an MGR2GTP.exe command in order to convert the disk from MBR to GPT. After that, NO MORE D4 and all cards were working flawlessly.

The other option would be to do a fresh install of Windows while CSM was disabled, that would have also worked, but I had done so much work on the drive that I had from another machine, I didn’t want to lose it.

So happy it’s working now!

I hope that this info helps someone out and saves them a load of time and headache!

3 Likes

Nice good job! :slight_smile: :+1:

1 Like