Asus sTRX4 motherboards S/PDIF out issue

So i migrated from x299 to sTRX4 platform and out of the box hit issue.
Issue is with audio in optical S/PDIF output in both Windows and Linux.

Issue Windows:

  • audio stops working after playing few songs / video clips
  • when changing audio / video crackling / popping sound can be heard from speakers

Tested with both Windows and Asus drivers same result.

Issue Linux:

  • S/PDIF out doesn’t work

NOTE: Line OUT DO work correctly for both Windows and Linux.
S/PDIF out is connected to speakers Edifier 2.1 S350DB with build in DAC.

Tested motherboards:

ASUS ROG Zenith II Extreme
ROG Strix TRX40-E Gaming

Asking here because ASUS did not reply to my inquiry.

If anyone has MSI Creator / or other sTRX4 mobo connected via optical share with us if audio do works for You in Linux.

Linux - tested Debian 10 (stable and testing), Ubuntu latest, Mint 19.3 - audio on optical don’t work.

Assuming your on the latest bios?

Yes this was first thing I did. All TR boards on 0702 bios, Windows 1909 (updated from 1903 to bypass that new broken “search on type” “feature”).

x299 - worked fine.

All those motherboards use same codec S1220 with TR adding SupremeFX.

Because of the design of the HD audio portion of TRX40, it’s actually going through USB internally rather than through the HD audio onboard codecs, because TRX40 has no onboard HD audio codec. You’re better off using a working USB solution rather than the non-working USB solution trying to translate HD Audio interface data to USB and back.

This is something AMD missed when designing TRX40.

I know this limitation and on Linux is probably early adopters issue. I’m fine with that, meaning that I can wait for fix.

What I’m not fine with is Windows side of things and issue on optic out.
There is another thread regarding SupremeFX codec:


The fact that ASUS didn’t even reply to me suggests that they know issue and are quiet about it.

About missed in design for TRx40 - isn’t it cost saving appraoch ? Realtek has a deal with Intel so AMD doesn’t need to $$$ for patents etc. to support it natively ?

No, what’s more likely what happened is because this was the first time AMD designed their own Zen chipset (ASMedia was doing it for them for a while) they focused on Epyc more than consumer for that chipset. On Epyc, the focus is getting IPMI working flawlessly, rather than getting desktop user features like audio working.

I’m not convinced that this is AMD issue.

I contacted other user with Aorus Master and he have different codec on board, same problem with Linux aka. no support for optical but in Windows it works correctly.

On my end audio also works, but it works incorrectly and I tested 2 different SKU motherboards so IMO issue is with ASUS implementation of that SupremeFX chipset. Pass-through via USB interface is issue but it’s not issue that I’m experiencing on optical.

At this point my only option is to go with MSI or GB but honestly I do like that Zenith II board. I have option to get myself other board for testing but I don’t want to as I spend to much time on assembly HW then using it ;/

Anyway to me most plausible explanation is that it’s ASUS issue and it will be fixed over time. I can live without SPDIF but there are also other issues - SATA | USB 3 performance drop but that’s TR issue IMO.

I have a gigbyte Aorus master, just built the system last night. I can confirm the same behavior in Linux. Linux kernel sees the audio device but no sound out of the optical port.

 cat /proc/asound/cards                             
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xb1080000 irq 166
 2 [Audio          ]: USB-Audio - USB Audio
                      Generic USB Audio at usb-0000:46:00.1-6, high speed
 3 [Audio_1        ]: USB-Audio - USB Audio
                      Generic USB Audio at usb-0000:46:00.3-5, high speed
 4 [Snowball       ]: USB-Audio - Blue Snowball
                      BLUE MICROPHONE Blue Snowball at usb-0000:23:00.3-, full speed
 5 [Schiit         ]: USB-Audio - I'm Fulla Schiit
                      Schiit Audio I'm Fulla Schiit at usb-0000:23:00.3-2.1.3, high speed
 6 [C920           ]: USB-Audio - HD Pro Webcam C920
                      HD Pro Webcam C920 at usb-0000:23:00.3-, high speed

lspci | grep -i audio
21:00.1 Audio device: NVIDIA Corporation GP104 High Definition Audio Controller (rev a1)
23:00.4 Audio device: Advanced Micro Devices, Inc. [AMD] Starship/Matisse HD Audio Controller
49:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)

I am running Siduction (Debian Sid/Unstable), with Kernel 5.4.10.

On windows the spdif works fine with the gigabyte drivers. I am not sure if Linux is reporting the right boost frequencies. Other than that loving this build.

Just chiming in here. I experience the same on the ASUS Zenith Exreme II Alpha as well. Been searching around, but this is the only place I have seen this issue even brought up. Anyone have any luck on a fix?

This was confirmed, assuming that this is not You, by yet another person with Zenith II Extreme here:

Basically this issue affect EVERY ASUS mobo for TRx40 this also include Linux, although there issue is with completely missing audio output - with is in works and will be release soon (if not out yet).

To be honest none of reviewers picked up issue with:

  • SATA performance issue
  • Linux missing support for RAID

I don’t know if this was because they don’t use it, use it only for testing for 2 days and return or purely luck - no use of digital out / SATA drives etc. or maybe love for underdog ???

Wandel also did mistake in his review pointing out that Asus board doesn’t support Ui for fan setup with is incorrect and doesn’t bode well for tech reviewer so, make of it what You want.

PS. last time I checked digi out was around posting this here so maybe now (2 BIOS updates later + probably many Windows updates - dunno have them disabled) they manage to fix this issue.

PS2. I did contacted AMD regarding slow SATA performance. In response I was told to run dxdiag and other software (forgot name, have it in email archive if anyone is interested) and send them logs. I did that and than looked what that other app gathered and log contained:

  • serial numbers for all software installed

So yeah, they never heard back from me.
Basically same is as with AMD GPUs, drivers and support SUCK big time !
Don’t want to say Intel is better, but at least on x299 everything worked out of the box for every OS and there wasn’t any strange issue. Well I was laying there was, I had ASUS Prime deluxe x299 mobo and ASUS was unable to correctly detect UEFI drives for 1 year so each time that I unplugged Linux drive I had to reinstall grub because mobo overwritten sh#$% in EFI. Bottom line I suspect this is ASUS bug with theirs Supreme Audio FX solution (POS HW ;/)

I beleive the S/PDIF issues impact all TRX40 motherboards.

There is a kernel bug here;

I’m also having this same crackling/popping issue

Some of my optical cables won’t even click into this port AT ALL – but the ones that do… crackling. I’ve tried multiple cables of course to make sure this was not the cable or speaker. It’s 100% something to do with the audio coming from the computer. / loose connection??

Anyway, just chiming in – in case someone finds a fix / or we get enough people who all say they have the issue that ASUS has to listen to us

1 Like

same thing is on Windows 10 :frowning:

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.