ASUS ROG GL752VW-DH71 - Quick Review & Linux Test | Level One Techs

Want a Level1 shirt? Please and thank you for the support! :)

Buy Now:

This is a companion discussion topic for the original entry at

Buy now:

1 Like

Nice review!

I have started to notice how your eyes shift back and forth between the camera lens and the camera live screen.

Nice review, it would be good to have the specs in metric for non american viewers.
Looks like a solid laptop, might have to have a closer look if the UK price is reasonable.

Pleased to see full linux compatibility, very nice, but I'm more pleased to see you testing this stuff in your reviews :D

p.s. Double check focus next time, Wendell has been out of focus for ten minutes.

Keep up the good work!!!

1 Like

Sorry for being a little late to the party but is it fairly standard now that USB 3.0 ports are not color coded blue anymore?

I'm really late to the post. But I want to install Linux on my device.
Can you make a post of How To? Because I tried to install Debian, Ubuntu and Fedora also, but the graphics drivers crashes, and there is only the console mode active.
I need a Step By Step here, Thanks

1 Like

Hello all!

I am also late to this post, however I purchased an ASUS ROG GL752VW-DH71 back in 10/2016

I have for the last week now been trying to get Qubes OS installed (tried 4.0 and 3.2) and I am having similar problems to ragutierrez above.

I have tried many kernel adjustments during the installer boot sequence, both in grub, and some weird non-grub gui menu that sometimes appears (efi menu maybe? I’m still lost in RE to efi). Kernel adjustments I have tried include disabling nouveau (see Qubes NVidia Troubleshooting Docs ), adjusting EFI settings during installer boot (before install, see Qubes EFI Troubleshooting Docs ), and a handful of other things (that I lost the links for).

After much trial and error, I was, once, able to get the installer started. It gave me a failure afterwards when trying to configure things, and I tried to re-install and now I’m stuck again.

I first tried Qubes 4, and then had minor success getting the install started only one time with Qubes 3.2.

I have tried Fedora 28, Fedora 24, Fedora 25, Tails, Kali, and I’m about to try Debian. So far, no luck.

The problem seems to be similar for all attempts:

The installers boot up and freeze or crash attempting to start X (Qubes is actually running “Xorg” command, whereas other distros are using startx or simply X). I the Qubes installers, sometimes I get to the tmux split text based installer and logger. Here, I see X fail to start up, and I can tab over to a different tmux screen, where I have a shell to use. Unfortunately, I find here every time (Qubes 4 and 3.2) that Xorg is actually running, and that it will not stop. I cannot kill it, I cannot use systemd to stop it, I cannot even soft reboot or soft shutdown. Everything fails stating that there was an error, or that there were processes that were waiting. I try to umount my flash drive, however I end up getting messages that the drive is busy, and I cannot seem to get things properly shut down, so I end up having to hard power down (which is hard, because the power key on the laptop consistently always powers the system BACK on).

Thank you for continuing to read my journey so far :slight_smile: If you’re still reading, and have had any success installing ANY distribution of GNU + Linux, I would be eternally grateful for any assistance. Even if the answer is to follow instructions from a link for an older pre 2016 distro.

I plan to replace the laptop soon, but unfortunately I’m between jobs currently, and I really need to something up and running so that I can hunt for jobs :slight_smile:, and when I do replace it I am likely to attempt something like the Librem 15.

Thanks in advance for any potentially offered help!