Asus R9 280x DCUII Top Artifacting

So i just got this card today and it was all fine and running smoothly until i played payday 2. So it started to artifact on that and i though must be a one off thing. I installed the newest beta drivers and that fixed payday 2. Went onto chivalry and played that for about 3 or 4 hours and no artifacting. Decided to play skyrim and now the card artifacts on every game i play now.

What i have tried.

New drivers.

Underclocking the card.

Tried to install the updated bios, but it tells me i already have the newest one.


Any help would be appreciated as i dont want to have to rma it to Asus as i will have to wait at least 3 or 4 months to get it back from Asus. (Asus's rma service is as shit as it can get in Aus)

return it get a new card.


Sadly the local store i go to might not do refunds. but i will try tomorrow and try and get a evga 770.

STAWP! Asus has released a bios firmware update for the artifacting! go to their support page and type in your information and go the the bios update. It should fix it!

I have already tried it and this is what i get.


lmfao dat error. no need dis...

I guess you could try to contact asus.

So far i have gotten rid of 95% or the artifacting through using the drivers on the gpu asus page. But i think it was mod on skyrim that made the gpu loose its shit. 

what version of AMD Catalyst are you using? Asus says to use version 13.251 or higher.