Asus Pro WS WRX80E-Sage won't power on... ideas?

It looks like I’m having the same issue as Asus Pro WS WRX80E-SAGE SE WIFI Trouble. I’ve had this board for almost a year, no issues. Super stable. Swapped out for more ram and added a couple of GPUs. I was concerned about the power levels with the 1550w PSU I had, but decided to go ahead and test. Put in new RAM, added two GPUs, had to move the PCIe cards around to do so, but there was no “rough treatment” of the board.

Now, it won’t boot at all. The BMC light flashes. The little power/reset buttons on the board are lit up. But, if you push the power button, nothing happens at all. No q-leds, no codes on the little LCD, nothing. I didn’t change at all how the board was mounted so I don’t think there are any issues with a mounting screw shorting it or anything.

I’ve tried:

  • Going back to exactly how it was before (same components)
  • Taking everything off the board except the CPU and one stick of RAM
  • Plugging in a different PSU (less power but should be enough to boot the board without GPUs)

The only other thing I can think of is to take the board out of the case completely to make sure nothing got messed up as I was moving it.

I can get into the IPMI web interface, but don’t see anything in any of the logs to give any info. Seems that it has just… died?

I would appreciate if anyone has any ideas for what else I could do? I’m looking to start an RMA next, but I’m not sure how long that will take.

Do you use the extra 2x8pin power connectors for the PCIe slots?

Yes, I connected all the power connectors, 24pin, 2xCPU 8pin, 1x8pin PCIe on front edge of board and both 6pin PCIe connectors on the bottom edge of the board. I also tried without the 6pin connectors on the bottom of the board.

Looks like it’s going to be an RMA. Tried to flash the bios as per ASUS instructions, didn’t work.

1 Like