Return to Level1Techs.com

ASUS Prime X370-Pro vs QEMU/Passthrough, latest BIOS updates don't work

Hi Everyone,

Below are basically information I would like to share with you all.

Upgrade:
I tried upgrade BIOS to latest 4801 and I did instantly regretted that.
The latest 4801 and 4602 don’t work with QEMU/Passthrough - kernel panic or freeze every restart/shutdown.

If you try to downgrade BIOS from latest 4801 it’s not possible using official BUpdater or EZ BIOS update utility as both do not allow downgrade.

I used old AMI update tool “afudos 4406.cap /x /p /b /n /k” and it worked fine.
I found downgrading method this reddit article in the comments:

old post:
Recently I’ve build new PC on AMD 2600 on ASUS Prime X370-Pro and two Nvidia PCIex cards. Obviously I’ve updated BIOS to (then) latest version 4602.
PC worked just fine on Windows and Linux except running QEMU with passthrough PCIex card or USB controller. System/kernel was crashing every time on reboot, when I’ve tried to run VM.
Situation resolved then BIOS downgrade to earlier version 4406. Everthing worked fine after downgrade.
Today I’ve noticed new BIOS version 4801 and I wonder if anyone using Linux/QEMU/Passthrough tried it already?

Kind Regards
Thom

Hello Thom,

I Still run Leap42, but with the Stable kernel 5.1, meaning I have to patch Vmware 15.1 for that ( thks rglinux and Michal Kubeček for this).

I am running Bios 4602 since a couple of weeks, and it stable with Vmware player 15.1 (patched) for my virtual machines, no freeze so far.

Can you give more details about your linux and kernel versions ? not sure i can help , but i, am interested.

i do not use Qemu in passthrough yet, but I follow Wendel vids about this and I seem to remember that there where some problems when the video cards are of the same models and that a cold reboot was required for the firmware load ( but this was a while ago BIOSes and kernel have evolved to better support Ryzen)

also with new ryzen2 support which is in the latest BIOSes, some side stabiliy effects could be (y)our problem :wink:

cheers

Dominique

Hi Dominique,

I’m using Manjaro KDE, with kernel 5.0.15 at the moment, waiting 5.1 to mature a little bit.

If I recall correctly problematic are AMD cards in my case both are nvidia, and both work fine with older bios so no reset problem here.

Kind regards
Thom

hello thom75 & level1techs,

any news to this? ive got the same problem with the latest version (5008) - same behaviour, freeze on reboot after starting not working reseted passthrough amd rx580 win-10 vm.

setup:

  • 1800x
  • 2x rx580
  • fedora 30 ws

tested with 5.2.0-0.rc7.git1.1 and 5.1.16

maybe relevant logs:
[ 159.958402] AMD-Vi: Completion-Wait loop timed out
[ 160.118777] AMD-Vi: Completion-Wait loop timed out
[ 160.799864] AMD-Vi: Event logged [
[ 160.799868] IOTLB_INV_TIMEOUT device=0a:00.0 address=0x000000043e8e8550]

after starting a vm with a passthroughed rx580 lspci -vnn returns “!!! Unknown header type 7f” on the guest card

downgrading to 4406 works for me, but not for my ordered 3900x :expressionless:
did you have any suggestions for a new board with working vfio?

I got no luck with this and basically I’ve given up with QEMU & passtrough graphics card. Updated BIOS to latest version and kind of enjoy dual boot with Windows.

Thom