Asus Maximus viii hero and Skylake 6700K

My experience with the VIII hero has been pretty good for the most part. Just a warning, when updating the bios it can do some funky stuff and reboot many times on its own. Im not exactly sure what happened because I flashed with no display and it just started doing stuff. It worked though xD.

I gave up trying to get Linux to run as I still have some bugs in windows 7 pro 64 bit that Im still trying to iron out. One thing is my Logitech C920 Webcam is not recognized on boot, I have to replug it for the LWS (webcam software) or windows to see it. Hangouts and skype need the same treatment. My mouse (G600) and keyboard (K95 RGB) are fine.
CUE has one bug, I have to delay startup because it actually starts faster than the USB 3.0 driver so it doesnt see the board. Replugging or restarting CUE is a work around or delay the startup of CUE (winpatrol or task scheduler).

This motherboard's asmedia sata ports are not great. Ive had speed issues with hdd's and ssd's on those ports and had to opt to not use them. Also Samsung Evo 850s are a little weird. Before I diagnosed the asmedia sata driver being a little weak I tried a couple different drives (samsung and sandisk) had to use only the intel controllers. Samsung behaviour was copying files would just hang randomly after a while, hdd led would stay on forcing a hard boot. After I switched it to an intel controller its fine. Since I installed linux and turned off secure boot the samsung drive causes the hdd led to stay on constantly for a minute or two after login then everything is fine. Haven't nailed that down yet.
The network drivers for LAN are wonderful no issue. Audio drivers are crap. I had so many issues with the audio drivers I had to uninstall and use windows generic drivers. Also I would recommend avoiding AI suite (no surprise) as it seems to mess with stuff.

Once I got everything into gaming order. It games well, stable at stock settings and what not. One crash on witcher 3 but i have no idea why. I think a bug created a short -_- we have a ladybug problem in the fall and spring.

Unsolved issues: USB problems, logitech C920 isnt recognized on boot, cant install old usb printer (says bios doesnt support usb install).

If anyone has any questions about the viii hero drop em below and I will try my best to answer questions concerning the cpu or mobo. Sorry for the scatter of text, end of day and wanted to get it all down in html.

First off I need the printer name model etc...

have you grabbed the asmedia drivers straight from there site? It really needs to be installed vanilla man or it will not work.

Logitech C920 how did you install it .. did you use the software suite ?

Please explain in better detail what the problems you are experiencing are?

Hey cinicrf,
First sorry for the lack of details as ive been meaning to get this down for a while and was tired. So:
HP Photosmart C3135 Inkjet. Generic drivers work well with it so may not even install the drivers from HP but the error said "cant install over USB, please check bios settings" Never seen that before, Im assuming its a USB legacy support setting somewhere.

I grabbed the asmedia drivers, both sata and usb, from The asus mobo site the first time I installed. They didnt jive well so I reinstalled windows and just installed everything from the asus mobo disk. That seemed more stable but I still had speed issues on the asmedia sata ports. Do you mean from the asus site or asmedia's site? (just updated to bios 1202 last night)

Logitech C920. I plugged it in after windows 7 was up to date, hangouts, skype picked it up no problem. After reboot I got usb device not recognized. Started unplugging things and isolated the webcam as the problem device. Installed latest LWS from logitech. It had me plug in the webcam during the install, everything was fine. IT just doesnt recognize it on boot I have to replug it for windows to recognize it, then everything is fine. It also worked on linux fine.

With regards to that 850 EVO, I have screwed with it and screwed with it. turns out turning off write-caching in device manager fixed the problem. With it turned on the drive would hang on boot. I only have games on it so windows is fine but as soon as I try to load a game after boot the LED goes solid and it hangs for 2-3 minutes then it runs normally. After changing drivers and trying other things I turned off write caching which seems to have fixed the problem. Im thinking of trying to turn it back on but also turning on the buffer flush.

Thanks for helping me throw ideas around. Helps to have a fresh set of eyes.