ASUS introduces its own IPMI card

The only thing “really necessary” should be a present 5 V standby power rail that can be deactivated by BIOS settings (“ERP ready” etc.). Even that should be optional if you were content with it only working with a manually powered-on system.

Can you provide screenshots from the IPMI web interface? Have you tried a different browser?

I’m on the same line of thinking as you… but then the cynical side of me is thinking ASUS programed in some kind of handshake with the motherboard’s bios in order for the ipmi card to fully start up so that they can ensure it’s only used with their MBs.

I’ll troubleshoot it some more tomorrow and post what I encounter. I had only tried chrome and edge to access the web interface before.

2 Likes

Well, I hope that that ass that took my package has no idea what he got there and that it still turns up - at the very least we then could find out if both samples behave the same.

3 Likes

I’m convinced that the IPMI’s webserver never initializes. I know what IP address it is receiving through DHCP (and the DHCP jumper is set on the card) and there is no response to that address no matter what browser I use (Firefox, Chrome, Edge, IE). If I try to access that IP address with IPMIView I am able to login only if I use the correct username and password, so I am sure I am accessing the device.

All the info is blank other than that the firmware revision of the card is 01.00.0C:

Requesting a power on via IPMI does not work even though the connection is made to the motherboard. If I manually power up the computer the amber light on the IPMI card’s rj45 port goes away and the card is no longer on the network, even if the computer is turned back off. the only way to have the IPMI card come back up on the network is to remove all power to the machine and then plugging the power supply back in.

Player 2 has entered the game.

  • There were “problems” with my package (Royal Mail didn’t specify which)

  • Package was previously opened

  • I hope I didn’t experience a sophisticated targeted supply-chain attack :upside_down_face:

  • I gave the card a nice warm IPA bath to not catch them monkeypox

Unfortunately or fortunately I think I’m making the same observations as @twin_savage

  • Card gets an IP address via DHCP but doesn’t seem to launch a web server :frowning:

  • Pinging to that IP address works without any issues

  • Nice: The motherboard header pins have the same thickness as the standard ones on motherboards themselves meaning ordinary Dupont cables can be used (ASRock Rack PAUL uses thinner ones so you’d need adapter cables)

  • When connecting the Power Switch pins between the AIC and the motherboard the motherboard powers on for a second before turning itself off again as soon as you connect the PSU to AC. Automatic power on after an AC disconnect is disabled in the UEFI, this is solely the doing of the ASUS card.

Any ideas what to try next?

Can you update the IPMI card’s firmware with the normal motherboard UEFI shell?

  • When ignoring everything and booting Windows the usual ASPEED dGPU shows up however Windows cannot find any drivers for an “IPMI Interface” device (Code 28):

Currently the only connected stuff is the USB cable with two channels, the Power Header and the 6-pin PCIe power cable

  • Removing the 6-pin PCIe power cable doesn’t change anything, I guess this is just supplementary power for the case that you torture the fan headers with an array of ungodly electricity-to-noise converters from Delta et al.

ASUS IPMI Expansion Card’s PDF manual:

2 Likes

Well, fudge…


Does anyone have an idea how to disable the BMC protection?

The manual doesn’t seem to mention this write lock at all :frowning:

dang.

Were you able to view the current BMC FW version on yours?
The 01.00.0C that was reported by IPMIView and the 1.1.13 that Asus released on 6/24 don’t seem to match up but perhaps that is supermicro not knowing how to read asus well.

We could try burning the firmware to the flash directly. The flash chip on mine is a W25Q512JV. I’m ordering an soic16 test clip now.

I’m not sure what chip select 1 and 2 are, I didn’t find any more spi flash on the board so I’m assuming its something internal to the ast2600 itself… shouldn’t cause a problem.

Nope.

Also tried the “static IP” jumper setting that is supposed to give the IP address 10.10.10.10 to the ASUS card, in that case I couldn’t even ping to it (used 10.10.10.11 on the other system for testing).

Searched around, would the method that is described for Dell updates work here (after booting Linux on the host, I guess?)?

Dell IPMI Firmware Upgrade

You can follow up the below steps to upgrade the FW of a Dell server.
Note: Don’t do FW upgrade over LIVE OS(may chance to broke the connection to server/ipmi)

Firstly download “socflash” from the respective site to update firmware.
Once it downloaded run the following commands to perform dell firmware update

yum -y install glibc.i686 ipmitool OpenIPMI
service ipmi start
tar xvf socflash.tar.gz
cd socflash
sh socflash.sh
service ipmi restart

ipmitool lan set 1 ipsrc static
ipmitool lan set 1 ipaddr X.X.X.X
ipmitool lan set 1 netmask 255.255.255.N
ipmitool lan set 1 defgw ipaddr X.X.X.Y
ipmitool user set name 2 ADMIN
ipmitool user set password 2

//adding VPS admin account:

ipmitool user set name 3 serveradminz
ipmitool user enable 3
ipmitool channel setaccess 1 3 link=on ipmi=on callin=on privilege=4
ipmitool user set password 3

//verification:
ipmitool mc info | grep “Firmware Revision”
Firmware Revision : 1.86

ipmitool mc selftest
Selftest: passed

Troubleshooting if ipmitool doesn’t work:

A)
rm /etc/modprobe.d/ipmitool-modalias.conf
service ipmi restart

B)
modprobe ipmi_msghandler
modprobe ipmi_si
modprobe ipmi_devintf

I think this is definitely worth a try; This is the first time I’ve encountered a write lock on a BMC firmware.
​ ​

​ ​​​

I just tried burning the firmware directly to the flash using a TL866II and it turns out the flash chip is too new of a model and I need to get a newer programmer.

2 Likes
  1. Could you confirm the BMC write protection? I’m pretty much a n00b here, prefering GUIs and stuff (if they at least work reliably, cough, ASRock Rack…)?

  2. Did you also observe the one second power-on of the motherboard if the ASUS AIC installed and hooked up to the motherboard front panel power switch header and then connect the system’s PSU to power?

  3. Thanks for documenting your experiments!

@twin_savage

Could you get your hands on the other/newer programmer for the firmware chip?

Can you “definitely” say which one I would have to get to participate?

Alright, so I can confirm that I am getting the same behavior as you when trying to use the v12207 SOCFLASH utility in dos to flash the bmc; it’s complaining that bmc is protected.

I started going down the linux route you posted but I could not find the appropriate version of the socflash utility for linux. It seems aspeed requires you to be registered as a developer to access that tool… I was only able to find the v12000 version of the tool for linux which unfortunately only goes up to a ast2500 chip.

I’m definitely going to get the newer programmer, I’ll be using it for other projects as well so its going to happen… I just haven’t decided which version of the newer programmer to get because now they have a fancy high end one I could get instead of the lower end one (either the T48 or the T56 will be able to program the W25Q512JV flash located on my ASUS IPMI card (I assume your card would have the same flash chip as mine)).

EDIT:
I ended up getting the T48, We’ll know if the firmware update helps by Tuesday.

2 Likes

I have some mostly bad news.
I was able to read the firmware off of the flash chip and flash in the new 1.1.13 fw. I can confirm that the 1.1.13 fw is different than what was originally on the card (CRC32 of 104E0F73 and F5B6D0BE respectively).

When accessing the card via IPMIView, it now shows the firmware revision as “01.01.0D” when I log into the IPMI; unfortunately there is no change in behavior, the functionality of the card isn’t working.

​ ​​​
Sort of good news depending on how you look at it, the following is now posted on ASUS’s website:

I’m really thinking I was right that there is a special handshake the IPMI card must do with the bios that ASUS must enable in bios in order for the card to work.

3 Likes

That’s disappointing that they would limit themselves like this.

Now I’m pretty sure this is why the system powers on for a second as soon as it gets power and then turns off immediately again, it’s the shitty DRM.

I get that real-time motherboard sensor monitoring or remote BIOS updates would require proper motherboard BIOS support but I can’t understand the limitation for the basic web server with KVM functionality and controls over the motherboard pin header.

Would maybe be interesting to check if the IPMI card works permanently after it had such a handshake?

2 Likes