Asus Direct CUII r9 290 not working but Reference Sapphire is

So I have a weird problem that I've spent nearly an entire weekend trying to fix. I am using an R9 290 Sapphire reference card and a recently purchased Asus Direct CUII R9 290. I use these in crossfire with an old Sapphire 5770 as a separate GPU.

I tried updating my drivers from 14.7 to 14.9 (I know I'm late but I had a similar problem going from I 14.4 I believe it was to 14.7. I was reluctant to try updating the driver until now and it basically screwed me over for trying it. It was pure luck to get 14.7 :P). I used a Driver Uninstaller utility I can't think of the actual name of it off the top of my head but basically I wiped the previous drivers and installed the current drivers. Here is the thing. 14.9 kind of works. Right now I am using the reference card and the 5770 fine but with the  Asus 290 in anywhere (as top or bottom card or by itself) it simply doesn't give a signal after windows starts booting up. I feel like this is a driver issue but is it? I booted into Lubuntu fine with the Asus card and can get around in the UEFI fine but not windows unless I just use the reference card only by itself or with the 5770. So I just want to know how to get my Asus card working again I miss my crossfire setup ;-; any help is appreciated thanks. 

Sorry forgot to put this in, not sure if it helps but I'm using windows 7 professional 64 bit as my windows os and 14.04 Lubuntu

  • why are you using a 5770 with 290's??? - they cant crossfire with each other as they are completely different. I could understand if you were say running a nvidia card as the 3rd gpu to handle physX but Im sure you wouldnt be maxing out the display outputs on the two 290's to warrant another card.
  • my advice - remove the 5770, run the dcu2 in the top slot, uninstall drivers, restart into safe mode, >>then use this<<, then reinstall drivers, insert 2nd 290 in the lower slot (being a reference design you want it to get the coolest air possible). Everything should be good, if not rinse/repeat with a different driver version.

I use the 5770 to power 3 monitors I don't use for gaming and to do all of my load for streaming and recording. Basically I found that doing this will give me no excuse for losing frames when doing anything while I am gaming. That and I used to mine doge-coin so it just gave me a couple hundred extra hashes at the time. 

Were you supposed to give a link for that? I'll try your advice if you are trying to link me to what I think you are trying to link me with (DDU: Driver Driver Uninstaller?)

Okay so I have been going through various versions of catalyst and they all have the same error after an install. The AMD Steady Video Plug-In is failing throughout all of these while everything else successfully installs. Is this the culprit as to why I have been having so many issues...? If so does this make finding a solution simpler? I also noticed that the reference card works fine after I do the same installation and simply ignore the error. Does this mean I have a bad card? Or am I just fearing the worst as there is a simpler solution? 


As I start up my computer to complete the driver installation... I get the UEFI splash screen windows boot screen... all the usual then I get a BSOD when I should be in windows. I know it has to do with the graphics card because it says something along the lines of atikmpag.sys or something along those lines as the error message. 

Obviously I try again. This leads to the usual boot up again. But where I got the BSOD I instead get a simple black screen and no matter how long I wait it just stays at that. This should be where I would actually log into windows. I hope this information helps. All of this was done with just the Direct CUII card as the only card installed in the system. 

Any other suggestions? I just settled on using the lateset 14.11 driver for now as using the latest driver would be best if I just keep getting a consistent error.