Asus 990fx evo rma. will it be horrible?

So I built this over Christmas. A couple of weeks ago I started having problems with the board (weird no post issues, random freezes while it idles). Tried new PSU, RAM, different GPU, all with the same result. Contact Asus for RMA. Start reading forums. Start getting worried about RMA, lol. Also on removing the GPU, the plastic tab on the end of that particular lane fell off. The card will still lock into the lane, I have just lost the handle on the end of it.

Have I just destroyed my chances of getting a new board? Is it worth even talking to them about it before I ship the thing off? Or should I just send it and roll the dice?

Also, can anyone recommend a decent alternative board from another manufacturer? I may just save myself the pain and buy a Gigabyte / MSI / Asrock alternative.

Thanks in advance for the advice!


Asus' RMA process shouldn't be bad.  Plenty of people have used that board with no problems

If you really want a new board from a different manufacturer:

ASRock 990fx Killer

Gigabyte 990(any 990fx board should be ok)

I've done an RMA with Asus before (the screen on my Nexus 7 cracked), it was pretty painless. They also treat their customers pretty well (they replaced my screen free of charge even though it cracked because I dropped it). So my experience with them has been pleasant.

if im right you can put the plastic locker back on. you probably did not unlock it, while taking out the GPU.

About the board issues, did you allready tried to update the bios to the latest version? version 2301 is the newest version.

Nah, it was unlocked, I put a different GPU in the lane to test the board, when we pushed the tab down to unlock it it felt like it was getting fragile, but unlocked the card. When I put the new one in, the end of the tab flew off and hit me in the forehead. Motherboard be angry, lol. The lane still works, I just have to push the tab down with a screw driver to unlock it. So no big deal, really. What set me off worrying was this:

There is also the possibility that I broke the thing due to installing it with hot dog fingers. If that's the case, fair enough I guess. :)

I did call Asus yesterday and explained about the lane issue. They said it shouldn't be a problem...



No you wont miss the lock. cause you screw the card anyway.

Only the other issues you have with the board, is something to be concerned about. if you still have the same issues, wenn updated the bios, then i would RMA the board. In My opinnion for AM3+ Asus is still the best way to go.

Yeah, it's running that BIOS. I reset the CMOS too. Tried a different PSU, GPU, memory and hard drive all with the same result. After that, I ran out of ideas after that and sent the thing back.


They have been pretty nice up to now. I deal with broken cars and the warranty shennanigans that come with that at work, so I see their side of this all day every day. It get's there tomorrow, I'll update as stuff happens if it's a rough go. 

Thanks for the support!



It's in repair right now, apparently. They're telling me I'll have it back next week at some point. Apparently it failed on it's own, so at least I didn't kill it, lol.

thats good news, they won´t repair it, i guess you get a new one.

Well, I got a shipping notice, so something is on it's way back. I spoke to Asus and they couldn't tell me if they had repaired or replaced it, which seems a bit curious. I'll see what turns up :)

Normaly its cheaper to replace, then to fix. especialy for such huge company's

Alright. It came back. Same board I sent em. They fixed the PCIE lane, sent it back in some random box, so I have lost my nice original packaging. It came back missing the back plate too. They still won't tell me what they fixed. I've thrown it back in the case. It gets switched on tomorrow. We'll see what occurs...

good. let us know what happens ☺

You'll like this. So I switch him on. No post. GPU led, yadda yadda yadda. Switch him off. Fiddle with cables. Switch him back on. Boot device light. No post. Bollocks. Unplug Boot drive, cycle power. No post. Unplug cheap $10.00 CD ROM drive. Boots right up. Guess What I didn't check before I RMA'd the board? I wonder if Asus actually fixed something or they are just to polite to call me stupid?



lol yeah they probably tested it and found nothing wrong with it. Then they put it back in another box to ship it back to you. It's not like they could figure out it was some cd rom drive to tell you to not use it. :D



It still freezes. It'll stay running for maybe 10 minutes. Then it locks up completely. Looking at Core Temp, six out of the eight cores on the CPU dropped to 0% before it did it. The CPU temp was 13 degrees C.

I am mightily confused. Is there anyone on here who lives in Phoenix and fancies coming on over to fix my shit? I have beer...

unfortunatly i live in the Netherlands lol, but i would personaly call asus about it,

There is something wrong with the board thats for sure. Or just call the seller. they need to fix this.


At least it works now.

Yup. Just talked to them. They want me to reset the CMOS (again) and flash the BIOS to the latest version. Because it came back from them with an older version of the software in it than it had when I sent it to them. Which makesno sense. The CMOS battery is under the GPU. Grrrrrr. I'll unplug it tonight and flash it tomorrow. Stay tuned for more in the continuing saga of "fuckwit PC repair"....