ASRockRack x570D40 no video

Hey there,

I switched from ltt forum, because someone there told me that the community here may potentially have more server nerds.

So here I am !

I build myself a little NAS Server with the X570D4U Mainboard from ASRockRack

After I hooked all ( CPU cooler, ATX Power, CPU Power, etc. ) correctly up to the board and pressed the power key it turned up the fans and did a restart.

I connected the VGA to the dedicated VGA Port from the Mobo which is powered by the BCM IPMI Chip but there is no output.

For testing I also put in a Zotac Geforce GT10 for video output but still no video.

After that I connected the dedicated IPMI Port to the Network.

Finnaly in the IPMI there were no CPU or GPU or even no RAM detected in the Peripherals tab. I also tried the KVM interface of the IPMI but there was a black screen and a text saying “No Signal”.

Even after several reboots and testings I couldnt get a video signal out of the Board.

Did anybody encountered this problem before or maybe has the same board at home and can give me some tips to fix my mainboard ?

( The ATX cable from the power supply was to short, so I extended it with a ATX extension cable from SilverStone )

btw. after all theese tests I did I think the board could be broken.

Thank You !

What ram are you using?

Can you list out all the hardware?

1 Like

It really sounds as if your CPU or RAM is not installed correctly, and isn’t running.

The IPMI works because it is an entirely separate system.

I haven’t used one of those ASRock boards but other systems I have used made the motherboard error codes available to the IPMI. Is there any kind of error log in there? I’m thinking it might have a simple (No CPU Found) or (RAM Error) or (Board Initialization Failure) or something.

Or yeah, the board could be broken.


Do you have a Ryzen 5000 installed on it by any chance? If so, you first need to update your bios through BMC/IPMI web interface.

1 Like

My hardware config is:

  • AMD Ryzen 5 3600
  • ASRockRack x570D40
  • Crucial CT16G4WFD8266
  • be quiet! ATX 400W System Power 9 BN245
    • extended with a SilverStone SST-PP07-MBB extension cable

Actually I updated the BIOS through the IPMI on first boot, so it should be fine.

Did you maybe forget about the CPU Power connector? I forget about that about 50% of times :slight_smile:

1 Like

Good call, but I realized it after I saw the CPU power cable from the PSU lying around in the PSU shroud :rofl:

in any case, the current BMC web gui doesn’t list any hardware even when booted. I’m guessing they still have a lot to update on the IPMI.
Does the PSU actually power on, like does it spin the fan?

Yeah the PSU works just perfectly fine. The LEDs on the Mobo light up as well ( one blinking green LED for the IPMI and one green LED for power )

you might have a DOA mate. test your cpu and ram somewhere else if you can and then return the mobo. :frowning:

about that ATX extension cable. double check the connections on all ends.

Status Update:

I have tested all recommended steps and even put the cpu on another board to make sure the CPU is ok and it worked.

  • Now I will contact my dealer to get a return and new board delivered asap

Thank You, for all of your support !

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.