Asrock z77 extreme4 A2/IDE detect error help?

posted this in motherboards cause im not really sure where it goes... might be a hardware issue, might be software..

I was curious if i would have to reinstall windows since i switched from an ASUS m3a78-cm on a Phenom II x4 944 to the asrock z77 extreme 4 and i5-3570k... i keep getting the error. all i have plugged in to the motherboard are the power connections, a few fans, my corsair h70, RAM (in the correct slot) and HDD

when i boot the A2 eventually dissapeares, but that is the last code on the Dr. Debug and windows goes into startup repair... but is unable to fix anything.

The HDD already has windows 7 64-bit Ultimate installed, as well as about 3 months of personal data.. would old drivers be messing this up since its such a huge change? It's the only drive i have so i'd rather not reinstall windows... otherwise ittle turn into a weekend project... 

if i get an SSD and fresh install windows 7 on that do you think it would work? then i could just delete windows off the HDD and keep my data..

not really sure what the problem is...

(yes, my keyboard is plugged in correctly (not in USB 3.0 slot) ive tried resetting the COMS, and the hardrive is selected as the primary boot option in BIOS)

Yes i have looked this up elsewhere and i cant find advice that has worked.


Did you just  swap over the old hdd you where useing to your new rig?


well thats the problem windows dosent like hardwhere changes you need to reinstall windows fresh for the new hardwhere 

alrighty, thanks for the help... was really hoping that wasnt the problem:/