ASRock X570 Taichi/Ryzen 9 3950X/RTX 2080 Ti System: Intermittent Video Stuttering When Capturing Video

The Problem:
When capturing video on my PC, whether through a capture card or using “Display Capture” in OBS (which doesn’t use a capture card), I get intermittent video stutter in the capture, even though there is no stutter on the display that is being captured. This happens in the video preview of the capture programs, even without recording or streaming. In OBS, there is no rendering or encoding lag shown in the stats.

See these two videos (watch them in full screen) on my YouTube channel:
Stuttering Video When Capturing Games Console: https://www.youtube.com/watch?v=bzT3Fi4_ulM
Stuttering Video When Capturing Cloned Display: https://www.youtube.com/watch?v=Ro-j5T-5UJQ

I initially thought the cause was my Elgato 4K60Pro MK.2, so I bought a different card—a Magewell Pro Capture HDMI 4K Plus LT—but the exact same problem persists with this capture card, too, which rules them out as the cause. I then discovered that the problem persists when using Display Capture in OBS, so the problem isn’t specific to using a capture card.

I normally have my Focusrite external audio interface plugged into a Thunderbolt 3 add-in card (a Gigabyte GC-Titan Ridge V1), which is plugged into PCIe Slot 5, so I tried disabling Thunderbolt in the motherboard’s BIOS. Problem persists. I then tried three different MB BIOSes (ASRock X570 Taichi BIOS versions 3.40, 3.00, and 2.70). Problem persists.

I tried OBS, VirtualDub, Elgato 4K Capture Utility, and Magewell Capture Express. Problem persists. I tried the x264 and new NVENC encoders, and various settings, resolutions, and frame rates in the programs where I could. Problem persists. The exact same video stuttering shows in all programs, whatever the settings are. As I said in the beginning, this happens whether I’m capturing a games console or I’m capturing my PC (in a single PC setup with either Display Capture in OBS (which doesn’t use a capture card) or via duplicating my desktop (which does uses a capture card).

I tried turning off my GPU overclocking software (MSI Afterburner). Problem persists. I tried disabling my second and third monitors. Problem persists. I tried disabling G-Sync and messing with various other settings in Nvidia Control Panel. Problem persists.

I tried updating Windows, all my software, drivers, firmware, etc. Problem persists. I tried a fresh install of Windows 10 on another drive (1 TB Corsair Force MP600) in another M.2 slot (Slot M2_2). (My main OS drive is my 2 TB Corsair MP600 drive, which is in Slot M2_1.) Problem persists.

I tried MANY other things! Problem persists.

So, I’ve ruled out capture cards, having Thunderbolt enabled in my BIOS, capturing programs and their encoding settings, and a dodgy motherboard BIOS. My CPU and RAM seem to be working well (they pass all tests in Memetest86). And my GPU seems to be working well (no crashing or glitching in testing and playing intensive modern 3D games). I plan on upgrading my GPU to the new AMD flagship GPU, which is PCIe 4.0, which my motherboard supports, so I’ll see if that changes anything; it’ll rule out Nvidia cards and drivers in general, if the problem persists.

My system:
Motherboard: ASRock X570 Taichi
CPU: Ryzen 9 3950X
RAM: 64 GB 3600 MHz HyperX Predator
GPU: MSI RTX 2080 Ti Gaming X Trio
Other PCIe card: Gigabyte GC-Titan Ridge V1 (Thunderbolt 3 add-in card)
Audio inferface: Focusrite Clarett 2Pre Thunderbolt (audio interface)
PSU: Corsair RM1000x

I’ve discussed this problem in my thread at the OBS forums here:

And I posted about it in a thread at the Linus Tech Tips forums here, where two other people have described the exact same problem as mine:

So! Anyway! Is the cause of this problem my motherboard? Is it faulty? Or is this a problem with all ASRock X570 Taichi motherboards? Or even all Zen 2 AM4 systems? Or does my motherboard not like my 2080 Ti? Or does it not like Nvidia GPUs in gerenal (in relation to capturing video)?

This problem has been driving me COMPLETELY INSANE!! So I was wondering if any of you here who also have an ASRock X570 Taichi and at least two monitors can help me out by doing a little experiment. PLEASE!

If you’d like to try to help me, here’s what I’d like you to do:

  • Download OBS (https://obsproject.com/download) and install it.
  • In your graphics card’s control panel, set your two monitors to the same resolution and refresh rate.
  • Open this motion test webpage on the display you want to capture: https://www.testufo.com/stutter#demo=smooth&foreground=ffffff&background=000000&pps=720 .
  • Set the motion test to “Smooth (VSYNC ON)”, set its speed to “Medium”, and then set it to full screen (the icon with green arrows at the top-right of the scrolling bar). (This should be showing no stuttering.)
  • Open OBS on another monitor.
  • In OBS, click on “Settings” in the controls, which is at the bottom-right, click on “Video”, and then set the Base and Output resolutions and “Common FPS Values” to match those of your two monitors.
  • In OBS, in your scene, right-click in the Sources window, select “Display Capture” and select your monitor that is viewing the motion test.
  • In OBS, right-click on the video preview, hover over “Fullscreen Projector (Preview)”, and then select the monitor that OBS is running on.
  • You should now have the motion test being displayed in full screen on two monitors: one being the display that is viewing the motion test, and one being the capture of the other display.
  • Ensure that there is no stuttering in the display being captured.
  • Now, compare the two. See if you notice any stuttering in the captured video.

And please let me know your results! Was there any stutter?!

Why can’t I post links on these forums? Do I try to communicate to you where I want you to go by using secretly coded messages or something? My post above is useless, otherwise. :frowning: Well, maybe not completely useless if anyone who wants to help can find the test at testufo[.]com that I’m talking about.

Don’t have experience with Video capture but hopefully a moderator can up your trust level manually so you can post links without being censored (Again, would @TheCakeIsNaOH be so kind?)

Bots seem to have been a problem (in the past?) so new users are prevented from posting links or private messages right away).

1 Like

Thanks for asking. I’ve edited the post to manipulate the links to get through the filter for now.

Done, @SJP176 you should be able to post links now.

@w.meri is doing a great job of dealing with them these days. The link prevention for new users is so we have a chance to find spambots before they actually start spamming links.

1 Like

Thanks. I’ll fix the links now. . . .

@SJP176

I don’t know if this has anything to do with your issue but could you “watch” your system for a few minutes without actively doing anything?

Sometime ago I had issues of which I was unable to pin-point the underlying cause that manifested in a way that sounded similar to your issues.

First noticed it on the desktop:

  • Every now and then the desktop icons would shortly flicker (the same way as if you select “Refresh” (F5), no GPU glitch)

  • When Windows device manager was open it showed the animation you get when you select “check for changed hardware”.

  • At least on my system nothing at that moment was recorded in the event log.

  • If this happens on your system these “strokes” might be the moments you experience video stutter.

This could be a case of drop frame vs non drop frame mismatch.

I’ve been trying to get EposVox to test this for the last year but he hasn’t budged.

The problem with trying to get TestUFO to produce consistent results… is it doesn’t. You need to create your own version of their tests in a NLE like Premiere and render that to a video file. Then you need to use dedicated playback hardware (an Atomos Ninja V) to play the file PERFECTLY to accurately gauge skipping frames.

This comes down to a fundamental problem with UVC in which it prefers non-drop, and when Windows grabs drop frame framerates, often the scaler in the UVC device already frame rate converted drop frame to non-drop, and then Windows is grabbing at a drop frame framerate, causing occasional desync.

Display Capture is extremely unoptimized. It drops frames by principal, therefore it’s an unfair test scenario.

The only fair test scenario is to capture a video of a test similar to TestUFO, except it’s playing on dedicated playback hardware that doesn’t drop frames. The better way to ensure no frames are dropped outside of TestUFO is to do a dual PC setup, where one PC is the HDMI source, and the other PC is the encoder with a dedicated capture card. Do not use a UVC device unless you are certain you can force the gaming PC to output perfect 60.00fps. Magewell and Blackmagic devices tend to work better with drop frame (59.94) framerates.

In Windows, the Nvidia Control Panel often DOESN’T distinguish between 59.94hz and 60hz. This is something you will need to research because there’s one other place to change refresh rate other than the NV Control Panel.

@aBav.Normie-Pleb
I haven’t noticed anything like this.

@FurryJackman
I don’t have the gear to test this, but I don’t think this is the problem. I get the exact same intermittent video stutter when capturing my Analogue Mega Sg console with both my Magewell and Elgato cards without their the HDMI passthroughs, where the cards report the console is outputting 60 Hz, and I have the capture program set to 60 Hz—no monitor is being used here.

Try turning off C-states, see if there’s DPC Latency issues, and turning on Message Signaled Interrupts. Make sure your card is not going through the PCH, and not going to a lane mux. Your x4 should be going straight to the CPU, so if you can use a M.2 riser to PCI-E x4 for the x4 lanes going straight to the CPU, that could help.

I know Killer NICs and WiFI cards cause severe DPC latency issues.

The other thing could be your SoC voltage is too low. You might want to raise it slightly or change the LLC level because an unstable FCLK can cause this too.

Unfortunately the Elgato rounds up from drop frame to non drop and doesn’t distinguish between 59.94 and 60hz.

Magewell has a scaler before the capture so you need to ensure the source, scaler and capture framerates all match.

@FurryJackman
I’d already tried turning off C-states (the person I’ve been discussing this with at ASRock Support suggested this to me). My GPU is in Slot 1, which uses the CPU PCIe lanes. And I’ve tried both my capture cards in both Slot 3, which also uses the CPU lanes, and in Slot 5, which uses the chipset lanes.

Already tried turning off Wi-Fi.

Tried setting SoC voltage to 1.2V and setting LLC to highest level. Problem persists.

Wouldn’t a frame rate mismatch exhibit regular stuttering? The stuttering that I get is irregular. Sometimes, it’s infrequent and not so bad; sometimes, it’s frequent and severe. When I recorded those videos, it wasn’t stuttering as badly as it sometimes does.

@FurryJackman
MSI is enabled for both my GPU and my capture card (using the Elgato at the moment).

@FurryJackman
Tried turning off the network card in the BIOS. Problem persists.

I think I’m going to give up now: I’ve wasted enough of my time on this over the past few weeks. I plan on upgrading my CPU and GPU in a few weeks, and if the problem still persists after that, I’ll buy a different X570 motherboard from another manufacturer (I don’t feel confident in trying another ASRock X570 Taichi or even a different ASRock X570 motherboard). I’ll post about how it goes then.

1 Like

The final thing you need to test is DPC latency. This might show you what’s going on.

I’ve already tested this with LatencyMon. It reports no problems.

Wow. Studio/Creator drivers for Nvidia then? Turning off the Desktop compositor? You need to send your machine to EposVox because if even he can’t figure it out, it’s cursed.

I’ve tried both Nvidia drivers. I’ve emailed EposVox and sent him a message through Twitter, but I haven’t heard back from him.

I’ve been discussing this problem through private messages with Scarftail from this forum thread, who has the exact same problem as I have:

He said his motherboard is an ASRock B450M/ac. He’s recently bought an Asus Tuf B365M-Plus Gaming motherboard, which he’s going to rebuilt his system with, and he’s going to let me know how it goes.

I messaged Fullmental, the OP of that thread, who also has this problem, but I haven’t heard back from him yet.

EposVox responds to Twitter DMs I think.

This is from ASRock x570 Taichi site

-1 x Thunderbolt™ AIC Connector (5-pin) (Supports ASRock Thunderbolt™ 3 AIC Card R2.0 only)

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.