Return to

ASRock X399 Taichi / Fatal1ty summary Thread


Yup, but that basically counts for most Gen1 boards.
If you want the 250W tdp cpu’s then a Gen2 board is really recommended,
like the Msi X399 meg creation or the Gigabyte X399 Extreme.
Would be nice to see Asrock coming with new boards aswell

[offtopic slightly]
I’m not sure how great the heat sinks are on the Msi boards.
Since i didnt had the board in my hands yet.
But in terms of current capability the Msi X399 Gaming pro carbon should be decent for 180W tdp chips.
The only complain i have is that i wished that they used IR3598 doublers instead of IR3599’s.
Because the IR3598’s do load current balancing, on which the IR3599’s is just a dumb doubler.
But other then that, all the spec’s look decent to me, atleast for a 180W tdp chip.
For the 250W tdp chip there is the Msi X399 MEG Creation.


The Asrock boards are pretty sollid aswell.
So yeah they are pretty good choices for the money.
One thing that is also important to look at which TR4 socked is used.
Not sure if Asrock has any plan’s for GEN2 boards with upgraded vrm’s aswell?
But i’m looking forward to see those.
Because Asrock is going well, i mean they could create an X399 OC Formula Ultimate board.
With 12 or 16 phases, with 70A powerstages for Vcore and 10Gb/e ethernet the whole nine yards.
Wont be cheap, but they could definitely steal some of Msi’s or Gigabyte market there.



Hello, I do have an ASRock X399 Taichi MoBo with the ASRock Ultra m.2 Card in which I have 4 Nvme SSD’s. No I wanted to install Ubuntu on a software raid 10, but Ubuntu does not recognize the nvme.

This is in Bios:

  • PCIe Bifurcation on;
  • AHCI on (not Raid)
  • Legacy on

Is there someone, which managed to install ubuntu on ssd’s on the ASRock Ultra Card? Thanks for help.



I wanted to post some things I found over the last three days building a rocket scientist friend an engineering WS using the ASRock X399 Fatal1ty board. This was my first TR system but I have built well over 500 computers since starting in 1985. I did quite a bit of research because he wanted 128GB and absolute stability. So I picked a TR2950 and this board. I read their memory recommendations for 8x16 and selected HyperX which went in yesterday and seems to be fine. Now for some of the frustrations building it:

First I was very careful installing the CPU and everything else. I didn’t have any problems and it went into the large Rosewill tower using a Rosewill 1050W PS with no problem. The Noctua CPU cooler was very nice and went on with no problems. First power up went perfectly and I was using two spare sticks of 4GB DDR4 from my Intel machine as the HyperX was not here yet. I then attempted a windows 7 install and it ran up to the “Starting Windows” notice and the machine hard rebooted. I tried a couple more times with the same result. I did some Googling and found IOMMU should be off so did that but still hard reboots at the beginning of windows install. I then suspected maybe memory so waited until yesterday when the new memory arrived. I installed 2x16 and it fired right up and the windows install rebooted it again. I was beginning to think the MB was bad. It had BIOS 3.30 and I knew there was a 3.50 but was a bit leery of flashing it because of the crashes and also I’ve had a couple of bad flashes in the past. But at this point the board looked like it would be going back so I carefully prepared it and ran the flash. Due to the file size it took much longer than in the past when I’ve done it but it flashed perfectly. So reboot and into windows and darn if that didn’t fix the problem. Hard to believe only two revs up on the BIOS fixed it and none of the notes on those two revs says anything about fixing windows install crashes. I attempted to install Win 7 but quickly found out my USB kybd and mouse would not work and did a bit of googling to find out AMD has stopped supporting windows 7 with their newer CPUs. So I asked my buddy if 10 was OK and while not happy he agreed. I installed 10 and it is working like a charm. Also of note, I used a Windows 7 Pro license today and it activated it fine. I then installed the rest of the memory in 2 stick increments and all worked fine. It is using a Corsair M510 1TB NVME drive and I will be adding a M510 2TB for him before he gets it. Also I am waiting for availability of a Quadro RTX 4000 WS video card and it will be complete. So if you are having any similar problems maybe these notes will assist you in your build. I am a very happy camper now and this machine screams.



Hello all,

I currently own an Asus Zenith Extreme. Debating an RMA for reasons I will likely post later in the Zenith thread. If I RMA’d I would most likely pickup an x399 Taichi because of the user base on this forum, and good reviews.

Could some please post up to date IOMMU Groupings, preferably with ARI Support and other relevant BIOS / UEFI settings enabled?

Posting the PNG from lstopo would be awesome too :slight_smile: but IOMMU is mostly what I’m concerned with.

If you’re interested in the use case, I’ll go post over in the Zenith thread about it. Thanks!



Well usb3.x and nvme are not supported out of the box with windows7.
However i believe that asrock provides a patch, that makes it possible to inject usb3.0 drivers in an existing windows7 iso.
This is the only way to get usb3 ports working during installation of windows7.
Same counts for nvme drives, you firstly need to inject drivers for it during install.

Another option is of course using a usb to ps2 converter, and use a ps2 keyboard during install.
If you have issues loading the windows setup from usb.
Then you could use a dvd instead.

But of course windows10 or 8.1 work fine aswell.
I understand that allot of people dont like windows10.
But yeah at some point you could ask yourself how much sense it makes to keep fighting agains obsolescence.



Hi guys, I have a Taichi X399 with a Threadripper 1950x, and I’m trying to figure out if I can run 2 GPU’s at x8 each on a single x16 pcie slot with something like this:

I looked in the bios and I only see an option for x4x4x4x4 mode for the x16 slots. Is this a no go?

Has anybody got something like this to work?



That particular splitter should work, update to latest bios and you should have x8x8 mode as well.



I’ve updated to the latest bios version 3.50 off the x399 Taichi support page: Taichi/index.asp#BIOS

The PCIe slot configurations still only offer x4x4x4x4 mode:

I’ve been on a few forums and seen a few people say that x8x8 mode is supported on this motherboard, but don’t understand where they are getting this information.



I’ve gotten a custom BIOS from the gents at ASRock (L3.51) to allow x8/x8 bifurcation. Just ask and I’ll send it.
Absolutely awesome support from ASRock!



Had the same issue of Ryzen not letting any ISB devices function on Windows 7. Windows 8.1 however worked fine



Check PCIe slot 3 for x8/x8 as well



Can anyone post up to date IOMMU groups for this board?

Or can anyone simply chime in and say if they can pass a usb controller to VMs safely?

Thanks in advance! It would be very appreciated!

1 Like


Thanks Bonkers for the BIOS, I’ll give it a go as soon as I can. Just had a system meltdown today, somehow the MBR on my system drive got corrupted, trying to recover it.

I plan on getting one of those splitters and testing it with some gpu’s. I’ll try and post an update when I do!



Were you able to test the BIOS? Any luck mate?
I decided to go for AMD EPYC instead, plenty of PCI-e lanes, and could use onboard gpu & IPMI.



Dont suppose anyone here knows the per die PCIe lane assignment for the x399 taichi?
I have been trying to find something like this for the taichi but so far no luck.



Hello guys. I noticed that no one posted there IOMMU / Numa Node layout for these X399 boards. Just in case someone was wondering…


Back Panel

IOMMU/Numa Node Summary

That shows both PCIe lans and USB devices. It shows if the slot in question is isolated or not as well as which Numa Node it is associated with.

Lastly, it shows which PCIe slot is the ‘bootvga’ depending on UEFI settings.

@brandon3055 is that what you where looking for… i mean it isn’t as detailed but it tells you which PCIe device is associated with which Numa Node… which i think is what you are concerned about?



Nice work!