Return to Level1Techs.com

ASRock X399 Taichi BIOS 3.60 USB Problems

Hello. Having random USB problems since updating to BIOS 3.60.

It seems to be mostly related to mice. My Razer Deathadder 2013 just turns off randomly and I have to unplug it for a couple of seconds and plug it back in for it to show up again.

I am using Arch 5.2.11. I am running VFIO/Looking Glass and both my mice (Razer and Logitech MX Master 2S) did not work when passed through.

The Logitech just never worked when passed through. No movement in guest or host until “I un-passed” it. I then started trying to pass through the Razer but, although it was successfully passed through for a couple of seconds, it then stopped working. “Un-passing” it through did not remedy the problem. Then, I started just using it just on the host and I experienced the same problem. The LEDs turn off and the mouse is not visible under lsusb until I unplug for 5 - 10 seconds and then plug in again.

I started a thread on reddit and there is one user that has reported USB problems as well with this BIOS version: https://www.reddit.com/r/VFIO/comments/cz793l/mice_just_dont_work/

@wendell Any chance you can test it out and maybe get your ASRock contacts to investigate?

I have this exact mouse and I have this problem across a whole host of devices. It does this exact thing on a dell thunderbolt dock and I think the hardware is haunted.

At worst it’ll show up for a sec, then kill other user devices on the same port, then come back for a sec, then kill stuff. It’s annoying.

I haven’t had any trouble from logitech with newer unifying receivers but I’ve been kind of reluctant to change much software on my machine.

I’ve seen the razer cause other usb devices to disappear and be flaky, though, so that might be related.

1 Like

Wow I was unaware of that. I used to use the Razer with this exact same setup from February till June without any problems.

Anyway, I experience the Logitech related problem regardless of the Razer being plugged in or not so I assumed it is a BIOS problem since one more user mentioned “mouse and sometimes keyboard not initializing in the vm” with VFIO or “usb related stalls or even hard lock ups” after updating to 3.60 in general.

@wendell I did some more digging, if I attach the Logitech mouse before the VM starts, then it works fine. If I try to attach while the VM is running, then it does not work. If I attach before it starts, use it in the VM, then detach and reattach again it does not work. Any ideas?

Edit: I tried with various VMs. In Linux VMs, the mouse works but there is no pointer. In Windows VMs the mouse does not work.

I also booted Windows bare metal and the mouse works like a charm.

Somebody please help!